Bug 5733 - Binding a third part library with three architectures causes all three libraries to be included in an app
Summary: Binding a third part library with three architectures causes all three librar...
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-06-19 05:26 UTC by Chris Hardy [MSFT]
Modified: 2013-12-05 18:35 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Chris Hardy [MSFT] 2012-06-19 05:26:35 UTC
A static library is commonly compiled in 3 platforms (armv6, armv7 and Simulator).

In a common XCode project, when I link a static library, the increase of the size related to the library it's only the third (if I compile the project for armv7 for example).

When I create an Obj-C binding library for monotouch, and I compile a final iOS application, it includes the 3 platforms of the library in the final app.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-03-11 09:39:32 UTC
Do you have a test project? We should only embed the relevant armv* parts of the static library.
Comment 2 Sebastien Pouliot 2013-06-03 20:12:47 UTC
I checked this not long ago and we were only linking the required architecture. Got a test case Chris ?
Comment 3 PJ 2013-11-19 17:05:25 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 4 PJ 2013-12-05 18:35:45 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.