Bug 57302 - AVPlayerLooper.LoopingEnabled Seems not to be present in Xcode9 nor Xcode 8.3 headers
Summary: AVPlayerLooper.LoopingEnabled Seems not to be present in Xcode9 nor Xcode 8.3...
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 10.99 (xcode9)
Hardware: PC Mac OS
: --- normal
Target Milestone: Xcode9
Assignee: Manuel de la Peña [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-06-08 23:32 UTC by Alex Soto [MSFT]
Modified: 2017-09-14 19:20 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alex Soto [MSFT] 2017-06-08 23:32:39 UTC
AVPlayerLooper.LoopingEnabled seems to be missing from Xcode 8.3 nd Xcode 9.0 Beta 1 headers, it was introduced in Xcode 8.0 so I disabled it in our xtro test and XAMCORE_4_0, I did not want to add an Obsolete because I am not sure what is the story of this property
Comment 1 Alex Soto [MSFT] 2017-06-08 23:33:49 UTC
@Manuel do you mind checking this since you bound iOS 10 AVFoundation? Thanks!
Comment 3 Sebastien Pouliot 2017-06-09 01:50:21 UTC
I don't recall seeing such a failure in xtro in the last 8.3 bindings
That also needs to be double checked
Comment 4 Manuel de la Peña [MSFT] 2017-09-11 23:02:23 UTC
PR can be found here: https://github.com/xamarin/xamarin-macios/pull/2650