Bug 57153 - "Xamarin Manual Installation Instructions" screen appears when using XamarinInstaller.exe because "XamarinIOS_BonjourResponder_Feature" was removed from .msi without coordinating a corresponding change in XamarinInstaller.exe
Summary: "Xamarin Manual Installation Instructions" screen appears when using XamarinI...
Status: RESOLVED DUPLICATE of bug 57152
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: --- major
Target Milestone: 15.3
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-06-05 21:33 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2017-10-22 16:14 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: Xamarin "15.1 release"


Attachments
Encountered this issue on Windows 10, Visual Studio 2013 (1.83 MB, text/plain)
2017-10-22 16:14 UTC, Elijah Lofgren
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 57152

Description Brendan Zagaeski (Xamarin Team, assistant) 2017-06-05 21:33:21 UTC
"XamarinIOS_BonjourResponder_Feature" was removed from .msi without coordinating a corresponding change in XamarinInstaller.exe




## Steps followed to test

1. Download the current latest Stable .msi installer.

2. Attempt to run the installer using the `msiexec` options used by XamarinInstaller.exe that worked with used to work with XamarinVS 4.4.0.34:

msiexec /i Xamarin.VisualStudio_4.5.0.476.msi /quiet /passive /log "%USERPROFILE%\Desktop\installer.log" ADDLOCAL=XamarinAndroid_MFASDK,XamarinPclProfiles,XamarinIOS_BonjourResponder_Feature,Xamarin_Bonjour,Apple_Bonjour,XamarinIOS_MonoTouchSDK,XamarinVSFeature,Xamarin_VS12_AddIn




## "Breakage" status: breakage in Xamarin "15.2 release" (XamarinVS 4.5.0)

BAD:  XamarinVS 4.5.0.476 (1be4f0c)
BAD:  XamarinVS 4.5.0.443 (c871575)
GOOD: XamarinVS 4.4.0.34  (3f99c5a)




## BAD Results with Xamarin 4.5.0.476.msi

The installation fails because "XamarinIOS_BonjourResponder_Feature" has been removed from the feature table:

> DEBUG: Error 2711:  The specified Feature name
> ('XamarinIOS_BonjourResponder_Feature') not found in Feature Table.



## GOOD Results with Xamarin.VisualStudio_4.4.0.34.msi

The installation runs successfully to completion.
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2017-06-05 21:33:30 UTC

*** This bug has been marked as a duplicate of bug 57152 ***
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2017-06-07 19:50:59 UTC
## Note to users watching this bug

The non-public Bug 57152 is a copy of this same bug filed against the XamarinInstaller.exe program to request that the `msiexec` command used in the XamarinInstaller.exe be updated to account for this change in the feature table.  Just as a matter of standard protocol, all bugs filed against the XamarinInstaller.exe program are non-public.  I will update this public bug report (Bug 57153) when the required change for the XamarinInstaller.exe has been published.
Comment 4 Brendan Zagaeski (Xamarin Team, assistant) 2017-06-07 19:54:18 UTC
## Tallying a few user reports for bookkeeping

2 users: https://forums.xamarin.com/discussion/96943/installation-fails-for-windows/p1 (2017-06-03 and 2017-06-07)
Comment 5 Elijah Lofgren 2017-10-22 16:14:45 UTC
Created attachment 25394 [details]
Encountered this issue on Windows 10, Visual Studio 2013

I ran into this issue today and attached is the log. Thanks!