Bug 57131 - App Crash instantly when connected to debugger
Summary: App Crash instantly when connected to debugger
Status: RESOLVED DUPLICATE of bug 56765
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 57136 ()
Depends on: 56765
Blocks:
  Show dependency tree
 
Reported: 2017-06-03 14:52 UTC by Emin Kokalari
Modified: 2017-06-12 13:38 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56765

Description Emin Kokalari 2017-06-03 14:52:35 UTC
It crash when debugging , and sometimes in release mode too with this messages :

E/art     (12972): Nested signal detected - original signal being reported

F/art     (12972): art/runtime/fault_handler.cc:117] Check failed: !initialized_

tried to set Target Android to 23 that didn’t work.

tried running adb shell setprop debug.mono.env
  MONO_DEBUG=soft-breakpoints that didn’t work.

tried to compile using different Android API's Versions
ANY IDEA WHY IS THIS HAPPENING ??

HERE IS MY CODE:

    public void start()
    {
        for (int i = 0; i < 50; i++)
        {
            Task.Run(() => RunScanTcp());
            //ThreadPool.QueueUserWorkItem(RunScanTcp);
            //Thread thread = new Thread(new ThreadStart(RunScanTcp));
            //thread.Start();
        }
    }


    public void RunScanTcp()
    {
        while (abort != true)
        {
                port = port + 1;
                Log.Info("PORT SCANNER", port.ToString());
        }
    }

Im compiling using :

Android Version (Android 7.1 Nougat)

Minimum Android Version :

Android 4.1 (API Level 16 - Jelly Bean)

Target Android Version:

Compile Using SDK Version
Comment 1 Emin Kokalari 2017-06-03 21:54:17 UTC
any help ?
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2017-06-05 18:41:08 UTC
*** Bug 57136 has been marked as a duplicate of this bug. ***
Comment 3 Marek Habersack 2017-06-12 13:38:34 UTC

*** This bug has been marked as a duplicate of bug 56765 ***