Bug 5709 - windoc.exe crashes on load
Summary: windoc.exe crashes on load
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 3.0.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jérémie Laval
URL:
Depends on:
Blocks:
 
Reported: 2012-06-18 13:00 UTC by Morkel
Modified: 2012-07-11 05:46 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Morkel 2012-06-18 13:00:46 UTC
After pressing F1 for help, after a few seconds I get a notification that WinDoc has crashed (happens every time).
- MonoDevelop is 3.0.3.1
- OS is WIn7 Pro Germany 64bit w/ SP1
Comment 1 Jérémie Laval 2012-07-05 10:40:46 UTC
Hi Morkel,

Could you look into the Windows Event Viewer (Applications section) for the
full stack trace of the crash? You can access the application through the search field in the Start menu.
Comment 2 Jérémie Laval 2012-07-09 07:07:07 UTC
May be related to https://bugzilla.xamarin.com/show_bug.cgi?id=5930
Comment 3 Morkel 2012-07-11 04:39:53 UTC
I found the cause of the problem by using MonoDevelop to debug WinDoc.exe:
On my machine, the directory "C:\Users\User\AppData\Roaming\WinDoc" was missing. The relevant exception info is:

{System.IO.DirectoryNotFoundException: Ein Teil des Pfades "C:\Users\User\AppData\Roaming\WinDoc\windoc.log" konnte nicht gefunden werden.    bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)    bei System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath)    bei System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)    bei System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)    bei System.IO.StreamWriter.CreateFile(String path, Boolean append)    bei System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encoding, Int32 bufferSize)    bei System.IO.StreamWriter..ctor(String path, Boolean append)    bei WinDoc.Program.SetupLogging()    bei WinDoc.Program.Main(String[] args)}

The error message is in German. It says "{System.IO.DirectoryNotFoundException: A part of the path "C:\Users\User\AppData\Roaming\WinDoc\windoc.log" could not be found.

I don't know why the directory was missing from my machine. I used the installer which came with MonoDevelop.
Comment 4 Jérémie Laval 2012-07-11 05:46:59 UTC
Hey Morkel,

This has been fixed in master, it should be part of the next release.

Thanks for reporting!