Bug 57044 - Xamarin.Forms Previewer doesn't load content, shows error message: Please upgrade your version of Xamarin.Android to enable custom controls.
Summary: Xamarin.Forms Previewer doesn't load content, shows error message: Please upg...
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.3.5
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-06-01 11:29 UTC by Elias Grauß
Modified: 2017-08-15 01:23 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Elias Grauß 2017-06-01 11:29:37 UTC
# Steps to reproduce
Open any .xaml file and open the Previewer. Choose Platform: Android
Device doesn't matter.

# Expected behavior
The Previewer loads the content of the .xaml file and displays the Android version in the preview window.

# Actual behavior
The previewer shows an error/information message: "Please upgrade your version of Xamarin.Android to enable custom controls.".
Instead of showing the content it shows a blue background and a busy indicator with the message "Initalizing renderer". Nothing happens and the content is not previewed.

# Supplemental info (logs, images, videos)
Log from AndroidDesigner.2017-06-01__08-06-31.log:
[2017-06-01 13:03:21.8] Renderer >> INFO: Trying to load class md5e940e1e778de0f856e343395a2f338c5.XFPageRendererView
[2017-06-01 13:03:21.8] Renderer >> 
[2017-06-01 13:03:21.8] Renderer >> Not loading custom component, monodroid is not ready
[2017-06-01 13:03:21.8] Renderer >> INFO: Trying to load class md5e940e1e778de0f856e343395a2f338c5.XFPageRendererView
[2017-06-01 13:03:21.8] Renderer >> 
[2017-06-01 13:03:21.8] Renderer >> Not loading custom component, monodroid is not ready
[2017-06-01 13:03:21.8] Renderer >> INFO: Trying to load class md5e940e1e778de0f856e343395a2f338c5.XFPageRendererView
[2017-06-01 13:03:21.8] Renderer >> 
[2017-06-01 13:03:21.8] Renderer >> Not loading custom component, monodroid is not ready
[2017-06-01 13:03:22.6] Renderer >> INFO: Trying to load class md5e940e1e778de0f856e343395a2f338c5.XFPageRendererView
[2017-06-01 13:03:22.6] Renderer >> 
[2017-06-01 13:03:22.6] Renderer >> Not loading custom component, monodroid is not ready
[2017-06-01 13:03:22.8] Renderer >> INFO: Trying to load class md5e940e1e778de0f856e343395a2f338c5.XFPageRendererView
[2017-06-01 13:03:22.8] Renderer >> 
[2017-06-01 13:03:22.8] Renderer >> Not loading custom component, monodroid is not ready

Screenshot: https://us.v-cdn.net/5019960/uploads/editor/8x/m0o8x1dpp747.png

# Test environment (full version information)
Xamarin Studio Community
Version 6.3 (build 864)
Installation UUID: f76db8cf-f605-4fc9-8af9-ebc50dcea162
Runtime:
	Mono 5.0.1.1 (2017-02/5077205) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 500010001

NuGet
Version: 3.5.0.0

Xamarin.Profiler
Version: 1.5.4
Speicherort: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

Apple Developer Tools
Xcode 8.2.1 (11766.1)
Build 8C1002

Xamarin.Mac
Version: 3.4.0.33 (Xamarin Studio Community)

Xamarin.Android
Version: 7.3.1.2 (Xamarin Studio Community)
Android SDK: /Users/Eliasgrauss/Library/Developer/Xamarin/android-sdk-macosx
	Unterstützte Android-Versionen:
		6.0 (API-Ebene 23)

Version der SDK-Tools: 25.2.3
Version der SDK-Plattformtools: 25.0.1
Version der SDK-Buildtools: 25.0.1

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL-Code ist hier verfügbar:
https://github.com/xamarin/AndroidDesigner.EPL

Xamarin Inspector
Version: 1.2.2
Hash: b71b035
Branch: d15-1
Build date: Fri, 21 Apr 2017 17:57:12 GMT

Xamarin.iOS
Version: 10.10.0.33 (Xamarin Studio Community)
Hash: 3e5ac5ff
Branch: d15-2
Build date: 2017-05-05 18:11:38-0400

Build Information
Release ID: 603000864
Git revision: 6c2f6737278ccc3e81e12276d49c0d92f975f189
Build date: 2017-04-24 11:26:01-04
Xamarin addins: d8d46e577d8507c35260ce9d73df3c33415bb214
Build lane: monodevelop-lion-d15-1

Operating System
Mac OS X 10.11.6
Darwin Eliass-MacBook-Pro.local 15.6.0 Darwin Kernel Version 15.6.0
    Thu Jun 23 18:25:34 PDT 2016
    root:xnu-3248.60.10~1/RELEASE_X86_64 x86_64

Enabled user installed addins
Gorilla Player 0.9.1.2
Comment 1 Jon Douglas [MSFT] 2017-06-27 17:12:04 UTC
Moving product to Forms for more visibility on the designer issue. As for reproducing, can you ensure you update to the latest version of Visual Studio for Mac to ensure this bug is still around?

I attempted this with a File->New Forms Project on Visual Studio for Mac:

Visual Studio Community 2017 for Mac 7.0.1 (build 24)

Xamarin.Android 7.3.1.2

Is there a specific page you are trying to load? If it's possible, please attach a project with the failing rendered .XAML to this bugzilla report so it's easier to reproduce on our end.

I am marking this bug as NEEDINFO until we have a way to confirm the behavior.
Comment 2 Paul DiPietro [MSFT] 2017-07-29 21:30:58 UTC
Due to a lack of response from the original reporter for 30 days and no reproduction, this will be closed. Please reopen this with a new attached project reproducing the issue if it still exist on the latest prerelease or nightly build.
Comment 3 DELAKEY 2017-08-15 01:23:39 UTC
Visual Studio Community work.
Xamarin Studio not working.