Bug 5703 - Theme selector broken in 4.2.3beta designer for VS2010
Summary: Theme selector broken in 4.2.3beta designer for VS2010
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 4.2.x
Hardware: PC Windows
: --- major
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2012-06-18 10:42 UTC by Justin Johnson
Modified: 2012-08-30 12:04 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screencap of bug (743.34 KB, video/x-ms-wmv)
2012-07-19 10:34 UTC, Justin Johnson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Justin Johnson 2012-06-18 10:42:28 UTC
After installing the 4.2.3 beta I am unable to preview themes outside of the default. When selecting a theme in the dropdown at the top right of the designer view, I used to see changes immediately reflected in the designer. Now the theme is not applied. The other buttons may not work, I didn't use them frequently before so I don't know if their behavior has changed but they seem to be unresponsive as well.


*The highest version I could select in Bugzilla was 4.2.1 but this bug only affects 4.2.3beta. I am using the designer as a Visual Studio 2010 plugin. Please advise if there is a better place to file this bug.
Comment 1 Atsushi Eno 2012-06-19 17:12:00 UTC
It seems none of the selectable elements on the UI designer (such as portrait/landscape, target Android profile (API level), dock modes) reflects users selection on VS2010 and VS2012.

I confirmed that MonoDevelop on Windows works fine.

(I noticed that portrait/landscape changes give background frame changes (which is almost transparent) on the designer surface. So maybe it is about communication with the actual designer process.)
Comment 2 Lluis Sanchez 2012-07-19 06:39:26 UTC
Can you still reproduce this problem with 4.2.4 ?
Comment 3 Justin Johnson 2012-07-19 10:34:14 UTC
Created attachment 2230 [details]
Screencap of bug

This is still present in 4.2.4, Visual Studio Designer.

This video shows changing themes, devices and orientation with no change to the design preview. Then, I close and open the document and the changes are applied.
You can also see Atsushi's comment about the background frame changing demonstrated here.

Sorry for the low video quality.
Comment 4 Lluis Sanchez 2012-08-30 12:04:55 UTC
Fixed. The fix will be included in upcoming releases.