Bug 56988 - Xamarin iOS SDK's out of sync between VS for Mac and VS2017 15.2
Summary: Xamarin iOS SDK's out of sync between VS for Mac and VS2017 15.2
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.3
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-31 04:06 UTC by mitchmuenster
Modified: 2017-07-12 09:21 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description mitchmuenster 2017-05-31 04:06:05 UTC
Latest Stable VS2017 install 15.2.2 is not updated with the latest Xamarin.iOS and Xamarin.Mac SDK's and theirfor is causing weird issues for building and will not sync up. VS2017 is using Xamairn.iOS 10.10.0.35 and VS for mac is using 10.10.0.36

hard to reproduce but here are the issues thus far that I have experienced more then once

- app just crashes, no explanation, no error, build host wont connect and iphone 7 plus running iOS 10.3 ui locks up
- after a build, buildhost is set to "limited" mode and refuses to build again. must kill and reconnect to build host, restart VS, and/or restart Windows to connect Again (no info in Xamarin Output window)
- iOS build over 5g WIFI connection to hardwired mac mini takes 30+ min to build (every time)
- build host randomly gets set into limited mode. Xamarin Ouput window shows following info:
Connected to the Mac Mitch’s Mac mini (192.168.1.112) with Full support.
Disconnected from the Mac Mitch’s Mac mini (192.168.1.112)
The underlying client has been disconnected by the remote host
Starting reconnection...
Starting connection to Mac 192.168.1.112...
Downloading /Users/mitch/Library/Logs/Xamarin-4.5/2017-05-30__22-42-30.6352.Broker.log...
Downloading /Users/mitch/Library/Logs/Xamarin-4.5/2017-05-30__22-42-30.6352.Broker.stderr.log...
Downloading /Users/mitch/Library/Logs/Xamarin-4.5/2017-05-30__22-42-30.6352.Build.log...
Downloading /Users/mitch/Library/Logs/Xamarin-4.5/2017-05-30__22-42-30.6352.Build.stderr.log...
Downloading /Users/mitch/Library/Logs/Xamarin-4.5/2017-05-30__22-42-30.6352.IDB.log...
Downloading /Users/mitch/Library/Logs/Xamarin-4.5/2017-05-30__22-42-30.6352.IDB.stderr.log...
Disconnected from the Mac Mitch’s Mac mini (192.168.1.112)
Starting connection to Mac 192.168.1.112...
Starting Broker 4.5.0.476 in port 50410...
Connection successfully established with the Mac 192.168.1.112:50410
Starting Agent Build 4.5.0.476...
Connected to the Mac Mitch’s Mac mini (192.168.1.112) with Limited support.
Agent Build 4.5.0.476 is running
Starting Agent IDB 4.5.0.476...
Agent IDB 4.5.0.476 is running

unable to remove out of limited mode without reconnecting. (happens randomly, Mac is not in use besides youtube, not locked, phone is not locked, and no disconnection request or dialog on either end has displayed.



**Note**
 I have fix mentioned in https://bugzilla.xamarin.com/show_bug.cgi?id=56213#c24 as mscorlib issue still is an issue for me even with update.
Comment 1 Jose Gallardo 2017-06-21 18:33:11 UTC
This issue is fixed on Xamarin 15.3