Bug 56987 - Duplicate zip entry [classes.jar:android/support/v4/view/ViewCompat$JbMr1ViewCompatImpl.class])
Summary: Duplicate zip entry [classes.jar:android/support/v4/view/ViewCompat$JbMr1View...
Status: RESOLVED ANSWERED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 7.3 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2017-05-31 03:19 UTC by mitchmuenster
Modified: 2017-06-23 18:38 UTC (History)
7 users (show)

Tags: bb
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin Log files of Downgrade and builds (4.22 KB, application/x-zip-compressed)
2017-05-31 03:19 UTC, mitchmuenster
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description mitchmuenster 2017-05-31 03:19:38 UTC
Created attachment 22568 [details]
Xamarin Log files of Downgrade and builds

After rolling back Zxing.Net.Forms nuget packages and updating VS to xamarin 15.2.2 i get the following error when trying to build with MULTIDEX enabled. which caused a downgrade of multiple android support lib packages refuses to build for targeting Android Nougat.

Can't write [C:\Users\mitch\AppData\Local\Temp\mainDexClasses-19047.tmp.jar] (Can't read [C:\Users\mitch\AppData\Local\Xamarin\Xamarin.Android.Support.v4\23.3.0.0\embedded\classes.jar] (Duplicate zip entry [classes.jar:android/support/v4/view/ViewCompat$JbMr1ViewCompatImpl.class]))	DriverAssistant.Mobile.Android	C:\Code\DriverAssistant.Mobile\DriverAssistant.Mobile\DriverAssistant.Mobile.Android\CREATEMULTIDEXMAINDEXCLASSLIST

		
Attempted to clean mentioned location by closing VS, deleting files, restarting pc, Deleteing any other files that would be deleted, and rebuilding.

Nuget packages for android & Forms at this time are:

<?xml version="1.0" encoding="utf-8"?>
<packages>
  <package id="CClarke.Plugin.Calendars" version="0.6.33-beta" targetFramework="monoandroid71" />
  <package id="DriverAssistant.Contracts" version="1.0.12" targetFramework="monoandroid70" />
  <package id="FastAndroidCamera" version="2.0.0" targetFramework="monoandroid70" />
  <package id="FormsToolkit" version="1.1.18" targetFramework="monoandroid71" />
  <package id="Humanizer.Core" version="2.2.0" targetFramework="monoandroid70" />
  <package id="Microsoft.Azure.Mobile" version="0.12.0" targetFramework="monoandroid70" />
  <package id="Microsoft.Azure.Mobile.Analytics" version="0.12.0" targetFramework="monoandroid70" />
  <package id="Microsoft.Azure.Mobile.Crashes" version="0.12.0" targetFramework="monoandroid70" />
  <package id="Microsoft.Azure.Mobile.Distribute" version="0.12.0" targetFramework="monoandroid70" />
  <package id="Microsoft.CSharp" version="4.3.0" targetFramework="monoandroid71" />
  <package id="Microsoft.NETCore.Platforms" version="1.1.0" targetFramework="monoandroid71" />
  <package id="Microsoft.Win32.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="modernhttpclient" version="2.4.2" targetFramework="monoandroid70" />
  <package id="NETStandard.Library" version="1.6.1" targetFramework="monoandroid71" />
  <package id="Newtonsoft.Json" version="10.0.2" targetFramework="monoandroid71" />
  <package id="Plugin.CurrentActivity" version="1.0.1" targetFramework="monoandroid71" />
  <package id="Plugin.Permissions" version="1.2.1" targetFramework="monoandroid71" />
  <package id="Plugin.Share" version="5.0.0" targetFramework="monoandroid71" />
  <package id="Refractored.MvvmHelpers" version="1.3.0" targetFramework="monoandroid70" />
  <package id="Refractored.XamForms.PullToRefresh" version="1.1.0" targetFramework="monoandroid71" />
  <package id="sqlite-net-pcl" version="1.3.3" targetFramework="monoandroid70" />
  <package id="SQLitePCLRaw.bundle_green" version="1.1.5" targetFramework="monoandroid70" />
  <package id="SQLitePCLRaw.core" version="1.1.5" targetFramework="monoandroid70" />
  <package id="SQLitePCLRaw.lib.e_sqlite3.android" version="1.1.5" targetFramework="monoandroid70" />
  <package id="SQLitePCLRaw.provider.e_sqlite3.android" version="1.1.5" targetFramework="monoandroid70" />
  <package id="System.AppContext" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Collections" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Collections.Concurrent" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.ComponentModel.TypeConverter" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Console" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Diagnostics.Debug" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Diagnostics.Tools" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Diagnostics.Tracing" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Globalization" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Globalization.Calendars" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.IO" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.IO.Compression" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.IO.Compression.ZipFile" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.IO.FileSystem" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.IO.FileSystem.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Linq" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Linq.Expressions" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Net.Http" version="4.3.2" targetFramework="monoandroid70" />
  <package id="System.Net.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Net.Sockets" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.ObjectModel" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Reflection" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Reflection.Extensions" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Reflection.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Resources.ResourceManager" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Extensions" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Handles" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.InteropServices" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.InteropServices.RuntimeInformation" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Numerics" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Serialization.Formatters" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Serialization.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Serialization.Xml" version="4.3.0" targetFramework="monoandroid70" />
  <package id="System.Security.Cryptography.Algorithms" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Security.Cryptography.Encoding" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Security.Cryptography.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Security.Cryptography.X509Certificates" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Text.Encoding" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Text.Encoding.Extensions" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Text.RegularExpressions" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Threading" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Threading.Tasks" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Threading.Timer" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Xml.ReaderWriter" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Xml.XDocument" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Xml.XmlDocument" version="4.3.0" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.Connectivity" version="2.3.0" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.DeviceInfo" version="2.1.2" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.ExternalMaps" version="3.0.10" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.Geolocator" version="3.0.4" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.Media" version="2.6.2" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.Version" version="1.0.0.0" targetFramework="monoandroid71" />
  <package id="Xam.Plugins.Forms.ImageCircle" version="1.8.1" targetFramework="monoandroid71" />
  <package id="Xam.Plugins.Messaging" version="4.0.0" targetFramework="monoandroid71" />
  <package id="Xam.Plugins.Settings" version="2.5.8" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Animated.Vector.Drawable" version="23.3.0" targetFramework="monoandroid60" />
  <package id="Xamarin.Android.Support.Annotations" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Compat" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Core.UI" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Core.Utils" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.CustomTabs" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Design" version="23.3.0" targetFramework="monoandroid60" />
  <package id="Xamarin.Android.Support.Fragment" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Media.Compat" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Transition" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.v4" version="23.3.0" targetFramework="monoandroid60" />
  <package id="Xamarin.Android.Support.v7.AppCompat" version="23.3.0" targetFramework="monoandroid60" />
  <package id="Xamarin.Android.Support.v7.CardView" version="23.3.0" targetFramework="monoandroid60" />
  <package id="Xamarin.Android.Support.v7.MediaRouter" version="23.3.0" targetFramework="monoandroid60" />
  <package id="Xamarin.Android.Support.v7.Palette" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.v7.RecyclerView" version="23.3.0" targetFramework="monoandroid60" />
  <package id="Xamarin.Android.Support.Vector.Drawable" version="23.3.0" targetFramework="monoandroid60" />
  <package id="Xamarin.Build.Download" version="0.4.5" targetFramework="monoandroid70" />
  <package id="Xamarin.Controls.SignaturePad" version="2.0.0" targetFramework="monoandroid70" />
  <package id="Xamarin.Controls.SignaturePad.Forms" version="2.0.0" targetFramework="monoandroid70" />
  <package id="Xamarin.Forms" version="2.3.4.247" targetFramework="monoandroid70" />
  <package id="Xamarin.Forms.AppLinks" version="2.3.4.247" targetFramework="monoandroid70" />
  <package id="Xamarin.Forms.Maps" version="2.3.4.247" targetFramework="monoandroid70" />
  <package id="Xamarin.GooglePlayServices.AppIndexing" version="29.0.0.1" targetFramework="monoandroid71" />
  <package id="Xamarin.GooglePlayServices.Base" version="29.0.0.1" targetFramework="monoandroid71" />
  <package id="Xamarin.GooglePlayServices.Basement" version="29.0.0.1" targetFramework="monoandroid71" />
  <package id="Xamarin.GooglePlayServices.Maps" version="29.0.0.1" targetFramework="monoandroid71" />
  <package id="Xamarin.GooglePlayServices.Measurement" version="29.0.0.1" targetFramework="monoandroid71" />
  <package id="XamarinUniversity.Core" version="1.0.161128" targetFramework="monoandroid71" />
  <package id="XamarinUniversity.Infrastructure" version="1.0.170503" targetFramework="monoandroid70" />
  <package id="ZXing.Net.Mobile" version="2.1.47" targetFramework="monoandroid60" />
  <package id="ZXing.Net.Mobile.Forms" version="2.1.47" targetFramework="monoandroid60" />
</packages>

Attempted to load latest ZXing.Net.Mobile.Form to see if would release the file and build and still refuses to let go. restored nuget packages to original state before downgrade and issue goes away. packages file now looks like:

<?xml version="1.0" encoding="utf-8"?>
<packages>
  <package id="CClarke.Plugin.Calendars" version="0.6.33-beta" targetFramework="monoandroid71" />
  <package id="DriverAssistant.Contracts" version="1.0.12" targetFramework="monoandroid70" />
  <package id="FastAndroidCamera" version="2.0.0" targetFramework="monoandroid70" />
  <package id="FormsToolkit" version="1.1.18" targetFramework="monoandroid71" />
  <package id="Humanizer.Core" version="2.2.0" targetFramework="monoandroid70" />
  <package id="Microsoft.Azure.Mobile" version="0.12.0" targetFramework="monoandroid70" />
  <package id="Microsoft.Azure.Mobile.Analytics" version="0.12.0" targetFramework="monoandroid70" />
  <package id="Microsoft.Azure.Mobile.Crashes" version="0.12.0" targetFramework="monoandroid70" />
  <package id="Microsoft.Azure.Mobile.Distribute" version="0.12.0" targetFramework="monoandroid70" />
  <package id="Microsoft.CSharp" version="4.3.0" targetFramework="monoandroid71" />
  <package id="Microsoft.NETCore.Platforms" version="1.1.0" targetFramework="monoandroid71" />
  <package id="Microsoft.Win32.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="modernhttpclient" version="2.4.2" targetFramework="monoandroid70" />
  <package id="NETStandard.Library" version="1.6.1" targetFramework="monoandroid71" />
  <package id="Newtonsoft.Json" version="10.0.2" targetFramework="monoandroid71" />
  <package id="Plugin.CurrentActivity" version="1.0.1" targetFramework="monoandroid71" />
  <package id="Plugin.Permissions" version="1.2.1" targetFramework="monoandroid71" />
  <package id="Plugin.Share" version="5.0.0" targetFramework="monoandroid71" />
  <package id="Refractored.MvvmHelpers" version="1.3.0" targetFramework="monoandroid70" />
  <package id="Refractored.XamForms.PullToRefresh" version="1.1.0" targetFramework="monoandroid71" />
  <package id="sqlite-net-pcl" version="1.3.3" targetFramework="monoandroid70" />
  <package id="SQLitePCLRaw.bundle_green" version="1.1.5" targetFramework="monoandroid70" />
  <package id="SQLitePCLRaw.core" version="1.1.5" targetFramework="monoandroid70" />
  <package id="SQLitePCLRaw.lib.e_sqlite3.android" version="1.1.5" targetFramework="monoandroid70" />
  <package id="SQLitePCLRaw.provider.e_sqlite3.android" version="1.1.5" targetFramework="monoandroid70" />
  <package id="System.AppContext" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Collections" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Collections.Concurrent" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.ComponentModel.TypeConverter" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Console" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Diagnostics.Debug" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Diagnostics.Tools" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Diagnostics.Tracing" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Globalization" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Globalization.Calendars" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.IO" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.IO.Compression" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.IO.Compression.ZipFile" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.IO.FileSystem" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.IO.FileSystem.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Linq" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Linq.Expressions" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Net.Http" version="4.3.2" targetFramework="monoandroid70" />
  <package id="System.Net.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Net.Sockets" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.ObjectModel" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Reflection" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Reflection.Extensions" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Reflection.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Resources.ResourceManager" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Extensions" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Handles" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.InteropServices" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.InteropServices.RuntimeInformation" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Numerics" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Serialization.Formatters" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Serialization.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Runtime.Serialization.Xml" version="4.3.0" targetFramework="monoandroid70" />
  <package id="System.Security.Cryptography.Algorithms" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Security.Cryptography.Encoding" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Security.Cryptography.Primitives" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Security.Cryptography.X509Certificates" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Text.Encoding" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Text.Encoding.Extensions" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Text.RegularExpressions" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Threading" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Threading.Tasks" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Threading.Timer" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Xml.ReaderWriter" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Xml.XDocument" version="4.3.0" targetFramework="monoandroid71" />
  <package id="System.Xml.XmlDocument" version="4.3.0" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.Connectivity" version="2.3.0" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.DeviceInfo" version="2.1.2" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.ExternalMaps" version="3.0.10" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.Geolocator" version="3.0.4" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.Media" version="2.6.2" targetFramework="monoandroid71" />
  <package id="Xam.Plugin.Version" version="1.0.0.0" targetFramework="monoandroid71" />
  <package id="Xam.Plugins.Forms.ImageCircle" version="1.8.1" targetFramework="monoandroid71" />
  <package id="Xam.Plugins.Messaging" version="4.0.0" targetFramework="monoandroid71" />
  <package id="Xam.Plugins.Settings" version="2.5.8" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Animated.Vector.Drawable" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Annotations" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Compat" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Core.UI" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Core.Utils" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.CustomTabs" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Design" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Fragment" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Media.Compat" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Transition" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.v4" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.v7.AppCompat" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.v7.CardView" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.v7.MediaRouter" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.v7.Palette" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.v7.RecyclerView" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Android.Support.Vector.Drawable" version="25.3.1" targetFramework="monoandroid70" />
  <package id="Xamarin.Build.Download" version="0.4.5" targetFramework="monoandroid70" />
  <package id="Xamarin.Controls.SignaturePad" version="2.0.0" targetFramework="monoandroid70" />
  <package id="Xamarin.Controls.SignaturePad.Forms" version="2.0.0" targetFramework="monoandroid70" />
  <package id="Xamarin.Forms" version="2.3.4.247" targetFramework="monoandroid70" />
  <package id="Xamarin.Forms.AppLinks" version="2.3.4.247" targetFramework="monoandroid70" />
  <package id="Xamarin.Forms.Maps" version="2.3.4.247" targetFramework="monoandroid70" />
  <package id="Xamarin.GooglePlayServices.AppIndexing" version="29.0.0.1" targetFramework="monoandroid71" />
  <package id="Xamarin.GooglePlayServices.Base" version="29.0.0.1" targetFramework="monoandroid71" />
  <package id="Xamarin.GooglePlayServices.Basement" version="29.0.0.1" targetFramework="monoandroid71" />
  <package id="Xamarin.GooglePlayServices.Maps" version="29.0.0.1" targetFramework="monoandroid71" />
  <package id="Xamarin.GooglePlayServices.Measurement" version="29.0.0.1" targetFramework="monoandroid71" />
  <package id="XamarinUniversity.Core" version="1.0.161128" targetFramework="monoandroid71" />
  <package id="XamarinUniversity.Infrastructure" version="1.0.170503" targetFramework="monoandroid70" />
  <package id="ZXing.Net.Mobile" version="2.2.9" targetFramework="monoandroid70" />
  <package id="ZXing.Net.Mobile.Forms" version="2.2.9" targetFramework="monoandroid70" />
</packages>

Why is VS hanging on to these files and can it be resolved so others who have to downgrade or do package management stuff can do so without important file lockups with multidexing?
Comment 1 James Montemagno [MSFT] 2017-05-31 13:31:10 UTC
I believe the issue here is that your Support libraries are all of different versions. You have some that are 25.x and 23.x I would recommend updating all of the support libraries or downgrading them back down to 23.x.
Comment 2 mitchmuenster 2017-06-01 02:15:56 UTC
Tried downgrading all support libraries to 23 and attempted a build. app would still give above error and not build. I now have uninstalled and reinstalled visual studio, which resolved the error.
Comment 3 Jon Douglas [MSFT] 2017-06-23 15:49:01 UTC
James is correct in that you shouldn't mix support library versions. 

The reason this happens is because when creating the main dex list via CREATEMULTIDEXMAINDEXCLASSLIST it is trying to add classes from android/support/v4/ multiple times, once from 23.3.0.0 and once from 25.3.1. Thus you'll see an error like the following indicating a duplicate zip entry:

Can't write [C:\Users\mitch\AppData\Local\Temp\mainDexClasses-19047.tmp.jar] (Can't read [C:\Users\mitch\AppData\Local\Xamarin\Xamarin.Android.Support.v4\23.3.0.0\embedded\classes.jar] (Duplicate zip entry [classes.jar:android/support/v4/view/ViewCompat$JbMr1ViewCompatImpl.class]))	DriverAssistant.Mobile.Android	C:\Code\DriverAssistant.Mobile\DriverAssistant.Mobile\DriverAssistant.Mobile.Android\CREATEMULTIDEXMAINDEXCLASSLIST

The other issue is that Android Support v4 23.3.0 does not split up the main packages, this doesn't happen until Android Support v4 24 which can also cause issues:

https://stackoverflow.com/questions/43597442/xamarin-android-conflict-between-assemblies/43597735#43597735