Bug 56943 - Recycle Element Image Cache Corruption Problem
Summary: Recycle Element Image Cache Corruption Problem
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-29 14:55 UTC by Hakan
Modified: 2017-06-17 21:38 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Hakan 2017-05-29 14:55:42 UTC
I tried it on Samsung Galaxy S3 with a ListView having an image in every row with a different web url.

The ListView had about 100 rows. When the ListView is scrolled fast, on average 5 images load as empty an waiting or changing the page and coming back does not help.

When using CachedImage of FFImageShow, this does not happen.

My initial guess is that when the url of the Image changes in ListView with caching strategy of RecycleElement due to fast initial scrolling, a cache image key is created by image loding and saving it to cache is cancelled. So the image cache for that url becomes corrupt.
Comment 1 Paul DiPietro [MSFT] 2017-05-29 17:14:16 UTC
Does this only occur on your S3? Have you experienced this issue on other devices, presumably older ones? A reproduction is helpful as well.
Comment 2 Hakan 2017-05-29 23:08:55 UTC
Unfortunately I don't have any other Android devices to try this on. And because it needs about 100 different images, it would be difficult for me to create a repro. I believe you will see it if you could test it on an actual Android device, preferably an older one, with just a simple listview on the page.
Comment 3 David Ortinau [MSFT] 2017-06-17 21:38:10 UTC
I've done this recently with FastRenderer Image (v2.3.5 pre-release) and several hundred rows. I was able to scroll rapidly. Loading off the web like this isn't ideal, but I did not observe this issue of images loading "as empty".

If this is still happening for you, please reopen the issue attaching a project that demonstrates this behavior.