Bug 56879 - [AssetEditor] Multiple readability issue in dark mode
Summary: [AssetEditor] Multiple readability issue in dark mode
Status: RESOLVED DUPLICATE of bug 33331
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.5.0 (15.2)
Hardware: PC Mac OS
: High normal
Target Milestone: 15.4
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-26 15:43 UTC by Vincent Dondain [MSFT]
Modified: 2017-06-21 18:09 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Asset Editor (dark mode) (366.67 KB, image/png)
2017-05-26 15:43 UTC, Vincent Dondain [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 33331

Description Vincent Dondain [MSFT] 2017-05-26 15:43:05 UTC
Created attachment 22509 [details]
Asset Editor (dark mode)

See attached screenshot:

I see the following problems:

1. There are clearly parts of the asset editor that are not "dark mode" enabled. Like the search area or the main section.
2. Readability issues with the side bar. As you can see AppIcons and LaunchImages texts are black on a black background.
3. Readability issues with the main section. The name of the individual assets (iPad Pro App, iPhone, iPhone Spotlight, etc...) are light gray on a white background. Same for the size at the center of the cells.

I don't know how big of an effort it is to make the entire asset editor play well with dark mode but if it turns out to be a long term effort, maybe we should just disable its dark mode support and have this section rendered like it is on light mode to avoid the readability issues.

Tested with the following environment: https://gist.github.com/VincentDondain/9e54ad828c6bdb771488112a55412cb0
Comment 1 Emanuel 2017-06-21 18:09:43 UTC

*** This bug has been marked as a duplicate of bug 33331 ***