Bug 56871 - [VS 2013] MEF composition error while opening the xaml previewer.
Summary: [VS 2013] MEF composition error while opening the xaml previewer.
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.6.0 (15.3)
Hardware: PC Windows
: High critical
Target Milestone: 15.3
Assignee: Adrian Alonso
URL:
: 57102 ()
Depends on: 57163
Blocks:
  Show dependency tree
 
Reported: 2017-05-26 13:10 UTC by Jacky Waswani
Modified: 2017-06-23 09:48 UTC (History)
10 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build:


Attachments
Logs_attached_preview_error (5.62 KB, application/x-zip-compressed)
2017-05-26 13:10 UTC, Jacky Waswani
Details
Screenshot_error_preview (198.55 KB, image/png)
2017-05-26 13:10 UTC, Jacky Waswani
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 3 Luis Aguilera 2017-05-30 21:12:14 UTC
as the bug only affects VS2013, I'm lowering the severity. I'm also marking this as a regression, as I believe this used to work in VS2013.
Comment 4 Alan McGovern 2017-05-30 22:51:54 UTC
If we're not planning on supporting VS2013 we can simply not fix it. Otherwise this is a blocker for alpha as our code must work in this IDE. Having it non-functional is not really an option.
Comment 5 Adrian Alonso 2017-06-07 14:45:13 UTC
*** Bug 57102 has been marked as a duplicate of this bug. ***
Comment 9 Alan McGovern 2017-06-08 14:09:40 UTC
This bug can be verified with a pre-existing project. It does not need to be verified with a template.