Bug 56763 - VS Sluggish
Summary: VS Sluggish
Status: RESOLVED NORESPONSE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Xamarin.Forms ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: 15.4
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-23 16:29 UTC by Hakan
Modified: 2017-07-24 20:12 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Hakan 2017-05-23 16:29:59 UTC
Although I have a 8-core 16 GB memory development PC, Visual Studio 2015 becomes sluggish when doing development on a Xamarin Forms solution. When I look at Process Explerer, I see that CPU usage is constantly between 4%-10% when VS is idle. Even scrolling constantly freezes. This happens even for newly created Xamarin Forms solutions but not for other types of solutions.

I used Performance Monitor in order to understand what is going on and saw that the following operations are constantly repeated almost every millisecond:




devenv.exe	RegOpenKey	HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{xxx}	REPARSE	Desired Access: Read	0.0000083
devenv.exe	RegOpenKey	HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{xxx}	SUCCESS	Desired Access: Read	0.0000106
devenv.exe	RegSetInfoKey	HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{xxx}	SUCCESS	KeySetInformationClass: KeySetHandleTagsInformation, Length: 0	0.0000059
devenv.exe	RegQueryValue	HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{xxx}\NameServer	SUCCESS	Type: REG_SZ, Length: 2, Data: 	0.0000102
devenv.exe	RegQueryValue	HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{xxx}\NameServer	SUCCESS	Type: REG_SZ, Length: 2, Data: 	0.0000095
devenv.exe	RegQueryValue	HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{xxx}\DhcpNameServer	NAME NOT FOUND	Length: 144	0.0000063
devenv.exe	RegCloseKey	HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{xxx}	SUCCESS		0.0000059
devenv.exe	RegQueryKey	HKLM	SUCCESS	Query: HandleTags, HandleTags: 0x0	0.0000095
devenv.exe	RegQueryKey	HKLM	SUCCESS	Query: Name	0.0000087


Can this be the reason why?
Comment 1 Jose Gallardo 2017-06-23 15:43:01 UTC
Hi @Hakan,

Can you please add the following information?

1. Xamarin Logs
Go to the menu "Help - Xamarin - Zip Logs". Please attach that zip file to the bug report.

2. Environment information
Go to the menu "Help - About Microsoft Visual Studio" and press "Copy Info". Please paste that info into a Bugzilla comment.


Also, after doing a full build for the solution (waiting until it succeeds), are you still facing this issue? There is a chance that this is caused by missing required Android support files (being downloaded to %localappdata%/Xamarin), and in that case doing a full build should ensure everything is fully configured.

Thanks
Comment 2 Pierce Boggan [MSFT] 2017-07-24 20:12:24 UTC
Because we have not received a reply to our request for more information, we are marking this issue as RESOLVED→NORESPONSE. If you are still encountering this issue on the latest Visual Studio 2017 Preview version 15.3, please don’t hesitate to reopen the ticket with the requested information. Thanks!