Bug 5668 - Object reference not set to an instance of an object at Mono.Debugging.Soft.SoftDebuggerAdaptor.GetTypeName
Summary: Object reference not set to an instance of an object at Mono.Debugging.Soft...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: Trunk
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-06-15 07:40 UTC by Marek Safar
Modified: 2012-06-15 13:39 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marek Safar 2012-06-15 07:40:13 UTC
when expanding object value in Watch window

System.NullReferenceException: Object reference not set to an instance of an object
  at Mono.Debugging.Soft.SoftDebuggerAdaptor.GetTypeName (Mono.Debugging.Evaluation.EvaluationContext ctx, System.Object val) [0x00046] in /home/marek/git/monodevelop/main/src/addins/MonoDevelop.Debugger.Soft/Mono.Debugging.Soft/SoftDebuggerAdaptor.cs:954 
  at Mono.Debugging.Evaluation.ObjectValueAdaptor.GetBaseType (Mono.Debugging.Evaluation.EvaluationContext ctx, System.Object type, Boolean includeObjectClass) [0x0000a] in /home/marek/git/monodevelop/main/src/core/Mono.Debugging/Mono.Debugging.Evaluation/ObjectValueAdaptor.cs:278 
  at Mono.Debugging.Evaluation.ObjectValueAdaptor.GetObjectValueChildren (Mono.Debugging.Evaluation.EvaluationContext ctx, IObjectSource objectSource, System.Object type, System.Object obj, Int32 firstItemIndex, Int32 count, Boolean dereferenceProxy) [0x003b5] in /home/marek/git/monodevelop/main/src/core/Mono.Debugging/Mono.Debugging.Evaluation/ObjectValueAdaptor.cs:473 
  at Mono.Debugging.Evaluation.ObjectValueAdaptor.GetObjectValueChildren (Mono.Debugging.Evaluation.EvaluationContext ctx, IObjectSource objectSource, System.Object obj, Int32 firstItemIndex, Int32 count) [0x00001] in /home/marek/git/monodevelop/main/src/core/Mono.Debugging/Mono.Debugging.Evaluation/ObjectValueAdaptor.cs:375 
  at Mono.Debugging.Evaluation.ValueReference.GetChildren (ObjectPath path, Int32 index, Int32 count, Mono.Debugging.Client.EvaluationOptions options) [0x00002] in /home/marek/git/monodevelop/main/src/core/Mono.Debugging/Mono.Debugging.Evaluation/ValueReference.cs:201
Comment 1 Jeffrey Stedfast 2012-06-15 13:39:32 UTC
fixed in git master