Bug 56571 - error : Could not load Info.plist
Summary: error : Could not load Info.plist
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: 15.4
Assignee: Emanuel
URL:
Depends on:
Blocks:
 
Reported: 2017-05-17 16:11 UTC by jcraig
Modified: 2017-07-20 20:45 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description jcraig 2017-05-17 16:11:12 UTC
This is only happening when building from the command line but our nightly build is failing with the following error:

"E:\Jenkins\jobs\CloudApps\workspace\Dictation\Dictation.iOS\Dictation.iOS.csproj" (default target) (7) ->
(_GetNativeExecutableName target) -> 
  C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(705,3): error : Could not load Info.plist: Could not find file "/Users/<OurUserName>/Library/Caches/Xamarin/mtbs/builds/Dictation.iOS/4cf4fed2df1a51fa4939c266aca0972c/bin/iPhone/Release/Dictation.iOS.app/Info.plist". [E:\Jenkins\jobs\CloudApps\workspace\Dictation\Dictation.iOS\Dictation.iOS.csproj]

    5 Warning(s)
    1 Error(s)

The only other issues are warnings about mismatch between MSIL and x86 versions of mscorlib. This started happening when our junior dev decided to update Xamarin Studio and when it prompted him to install VS for Mac, he did that. So it added VS to the Mac and now the above error. We have not removed Xamarin Studio if that makes a difference. Anyway, here is the version info from the new VS install:

=== Visual Studio Professional 2017 for Mac ===

Version 7.0 (build 3146)
Installation UUID: 4c661789-3a6e-4cb2-b31a-5045c32d7c1b
Runtime:
	Mono 5.0.0.100 (2017-02/9667aa6) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 500000100

=== NuGet ===

Version: 4.0.0.2323

=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
SDK: /usr/local/share/dotnet/sdk/1.0.3/Sdks
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.0.0/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.4
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 8.3.2 (12175)
Build 8E2002

=== Xamarin.Mac ===

Version: 3.4.0.33 (Visual Studio Professional)

=== Xamarin.Android ===

Version: 7.3.0.13 (Visual Studio Professional)
Android SDK: /Users/<OurUserName>/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		6.0 (API level 23)

SDK Tools Version: 25.1.2
SDK Platform Tools Version: 24.0.0
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Inspector ===

Version: 1.2.2
Hash: b71b035
Branch: d15-1
Build date: Fri, 21 Apr 2017 17:57:12 GMT

=== Xamarin.iOS ===

Version: 10.10.0.33 (Visual Studio Professional)
Hash: 3e5ac5ff
Branch: d15-2
Build date: 2017-05-05 18:11:38-0400

=== Build Information ===

Release ID: 700003146
Git revision: 7553fda2e327d15807298d444007896e5b975dba
Build date: 2017-05-09 12:12:36-04
Xamarin addins: c3d580752be79fc902422f1d55d1cdc2d8b98799
Build lane: monodevelop-lion-d15-2

=== Operating System ===

Mac OS X 10.12.5
Darwin 16.6.0 Darwin Kernel Version 16.6.0
    Fri Apr 14 16:21:16 PDT 2017
    root:xnu-3789.60.24~6/RELEASE_X86_64 x86_64
Comment 1 Emanuel 2017-07-19 21:37:50 UTC
Hi jcraig,
Sorry for the late response. I've been trying to reproduce this issue but unfortunately I couldn't hit it, so I have a couple of questions for you that might help me to find the issue:
1) Are you still able to reproduce this issue?
2) Did you update Xamarin for Visual Studio (Windows side) after installing VS for Mac? VS for Mac installs a new version of Xamarin.iOS on the Mac, and it should be on sync with the Xamarin.iOS installed on Windows.
3) Could you attach the Visual Studio (Win) environment info from the bot that's running your nightly builds (Help -> About Microsoft Visual Studio -> Copy Info)?
4) Could you attach a full diagnostic build output?

Thanks!
Comment 2 jcraig 2017-07-20 13:21:25 UTC
I just talked to the team members who took over the mobile development. Apparently the issue no longer occurs. They've updated both the Windows and Mac side and it went away. Unfortunately they are unable to pinpoint for me when it went away as they were doing the builds manually for a while before noticing the build server was back to normal. I think at this point you guys can probably close the issue.
Comment 3 Emanuel 2017-07-20 20:45:31 UTC
Thanks for the confirmation jcraig! Please, keep in mind to keep both Xamarin.iOS versions (Windows and Mac side) on sync. If you update VS for Mac, you'll need to update Xamarin for VS on Windows, and that's probably what fixed your team's issue.

I'm marking this bug as Not Reproducible per comment2.