Bug 56419 - Merged Dictionary not working in custom renderer
Summary: Merged Dictionary not working in custom renderer
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Paul DiPietro [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-05-14 00:31 UTC by predalpha
Modified: 2017-06-16 14:49 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description predalpha 2017-05-14 00:31:18 UTC
Hello,

Merged dictionaries are not working when i try to access it from CustomRenderer.
Dynamic resources always return base dictionary value, not the merged one.

 public class EditorRendererEx : EditorRenderer
    {
        protected override void OnElementChanged(ElementChangedEventArgs<Editor> e)
        {
            base.OnElementChanged(e);

            if (Control != null)
            {
                Xamarin.Forms.Color color = (Color)Application.Current.Resources["foreColor"];

}}}
Comment 1 Paul DiPietro [MSFT] 2017-05-16 16:17:15 UTC
Hi, could you please upload a minimized reproduction project demonstrating the issue in full? Thanks!
Comment 2 Paul DiPietro [MSFT] 2017-06-16 14:49:08 UTC
This issue will be closed due to a lack of response. Please reopen this and attach a minimized reproduction project if the issue still exists as of the latest prerelease or nightly build.