Bug 56393 - Project doesn't build after enabling Proguard
Summary: Project doesn't build after enabling Proguard
Status: RESOLVED DUPLICATE of bug 32861
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2017-05-13 17:52 UTC by Akash Kakkar
Modified: 2017-05-17 16:38 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin logs (2.99 KB, application/x-zip-compressed)
2017-05-13 17:52 UTC, Akash Kakkar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 32861

Description Akash Kakkar 2017-05-13 17:52:30 UTC
Created attachment 22157 [details]
Xamarin logs

After enabling proguard in the project/app, project doesn't build.
The following error comes:
Error		"java.exe" exited with code 1.
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2017-05-13 18:40:05 UTC Comment hidden (obsolete)
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2017-05-17 04:56:17 UTC
Correction to Comment 1:

Xamarin.Android 7.3 is already included in the Xamarin 15.2 Release, and the log files from Comment 0 show that the reporter is using the Xamarin 15.2 Release (XamarinVS version 4.5.0.443-d15-2+c871575).  This means that the Java JDK version of 8 (1.8) is OK, and the space in the Android SDK path (related to Bug 33052 and Bug 32861) is the most likely remaining problem.  I will accordingly mark Comment 1 as obsolete.

From the attached monodroid*.log file:

> ANDROID_SDK_HOME found: C:\Program Files (x86)\Android\android-sdk




## Corrected next steps


1. Move the Android SDK to a path without spaces such as C:\android-sdk


2. Update the Android SDK path setting in Visual Studio under "Tools > Options > Xamarin > Android Settings > Android SDK Location".


3. Attempt to build the project that uses ProGuard once more.


4. If the build still fails, please collect and attach back the diagnostic build output:

a. Set "Tools > Options > Projects and Solutions > Build and Run > MSBuild project build output verbosity" to Diagnostic.

b. The next time you build the project the diagnostic MSBuild output will now be visible in the Output window.

c. Once you hit the error again, you can save the diagnostic MSBuild output to a file via "File > Save Output As...", zip it up, and attach it back.



Thanks in advance!
Comment 3 Akash Kakkar 2017-05-17 05:14:18 UTC
Brendan,
ya, it's fixed after changing the Android SDK path. you can close this bug
Comment 4 Akash Kakkar 2017-05-17 05:15:20 UTC
The issue is fixed after changing the android sdk path
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2017-05-17 16:38:05 UTC
Excellent.  Thanks for the follow-up.  I will mark this as a duplicate of the old related Bug 32861 just for thorough bookkeeping.

*** This bug has been marked as a duplicate of bug 32861 ***