Bug 56305 - Setting visibility to gone for for TabLayout does not reclaim space
Summary: Setting visibility to gone for for TabLayout does not reclaim space
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.3.5
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-12 17:25 UTC by Paul Brenner
Modified: 2018-02-09 18:24 UTC (History)
4 users (show)

Tags: ac fr
Is this bug a regression?: ---
Last known good build:


Attachments
sample showing issue (72.76 KB, application/x-zip-compressed)
2017-05-12 17:25 UTC, Paul Brenner
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Paul Brenner 2017-05-12 17:25:20 UTC
Created attachment 22136 [details]
sample showing issue

I'm trying to hide the tabs in TabLayout when a page is pushed. When I set visibility to gone, the tabs are hidden but space is not reclaimed. Please see repro.

Tested on 2.3.4.231 and 2.3.5.239-pre3

NOTE: this is super similar to bug #43108 but I couldn't figure out how to re open a bug.
Comment 1 adrianknight89 2017-06-17 18:45:33 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/999

Your bug is different from #43108 because each of your tab items is a NavigationPage as opposed to a plain ContentPage. I submitted some changes to help redraw the NavigationPage.
Comment 2 Paul Brenner 2017-12-12 18:54:39 UTC
Changing back to confirmed since the PR was closed (https://github.com/xamarin/Xamarin.Forms/pull/999). This is a 2 line code change, can someone from the team please look at the failing UI tests ?
Comment 3 Paul Brenner 2018-02-09 18:24:16 UTC
Migrated to github https://github.com/xamarin/Xamarin.Forms/issues/1855