Bug 56239 - Since Last Xamarin Studio Update Trouble Building With Error executing task XamlCTask
Summary: Since Last Xamarin Studio Update Trouble Building With Error executing task X...
Status: RESOLVED DUPLICATE of bug 54692
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Stephane Delcroix
URL:
Depends on:
Blocks:
 
Reported: 2017-05-11 17:49 UTC by Paul Hart
Modified: 2017-05-16 16:27 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 54692

Description Paul Hart 2017-05-11 17:49:08 UTC
A day or two ago (today is 5/11/17) I got an upgrade message in Xamarin Studio for Mac while working on an iOS Project. The iOS project has a Forms foundation with lots of custom renderers.

After upgrading using the notification dialog that asked me to upgrade, I got the following error:

Error executing task XamlCTask: Could not find file "{Path to File}/{Assembly Name}.exe.mdb"

I googled around and saw I should upgrade my Xamarin.Forms package and I did so to 2.3.5.239-pre2 on 5/10/17. I was able to build right off the bat with the current branch. After I changed a few class files I got the error list above again. Note I did not change any project or solution settings so it made no since. I reverted my changes, exited Xamarin Studio and did a manual clean. I was able to get it to build. If I restored a stash with 2 class files it would give me the error again so I had to manually copy the new functions to the class files and it would build. 

Then today I saw that 2.3.5.239-pre3 was out. After upgrading to this new version I am getting the error again. 

I am really confused why changing class file functions which have no build errors make the error listed above occur. It seems really flaky. 

It seems the only solution is to keep cleaning / reopening Xamarin Studio ... it has taken me way offline and is not related to any coding errors.
Comment 1 Paul Hart 2017-05-11 20:29:47 UTC
Note the solution so far seems to be downgrade to pre2 if it happens or upgrade to pre3 if it happens. I am very confused and annoyed right now.

At one point I got around 500 build errors and upgraded from pre2 and pre3 and it worked again ... Its just a back and forth pain in the butt.
Comment 2 Sebastien Pouliot 2017-05-11 20:34:17 UTC
XamlCTask is a tool (msbuild task) shipped with Xamarin.Forms (not Xamarin.iOS). Re-assigning
Comment 3 Paul DiPietro [MSFT] 2017-05-16 16:27:53 UTC

*** This bug has been marked as a duplicate of bug 54692 ***