Bug 56214 - Json.Net 10.2
Summary: Json.Net 10.2
Status: RESOLVED DUPLICATE of bug 56246
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: 5.0.0 (2017-02)
Hardware: Macintosh Mac OS
: High normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2017-05-11 09:35 UTC by Curia Damiano
Modified: 2017-05-26 16:37 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Demo project (33.13 KB, application/x-zip-compressed)
2017-05-11 09:35 UTC, Curia Damiano
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56246

Description Curia Damiano 2017-05-11 09:35:41 UTC
Created attachment 22078 [details]
Demo project

Hi,
I'm unable to use JSON.Net 10.2 compiling from Xamarin Studio 15.2 (same problem on v15.1).
The same project compiles successfully on Visual Studio 2017 (and VS2017.2) for Windows.
I get the following exception: ""

I attach a repro project showing the problem: it compiles on VS2017 but not on Xamarin Studio 15.2.
On Visual Studio for Mac GA it gives also an additional problem.

Please also note that in this demo, the main iOS project is configured to build on VS2017, but Xamarin Studio thinks that it is excluded from the active configuration (the same for VS4Mac)
Comment 1 Kirill Osenkov 2017-05-11 22:15:50 UTC
Possible dupe of https://bugzilla.xamarin.com/show_bug.cgi?id=56086
Comment 2 Curia Damiano 2017-05-12 12:29:35 UTC
Hi,
the error message was indeed about System.Runtime missing (as the other bug you suggested).
The difference is that in my case, it makes the project failing to compile.
Regards, Damiano
Comment 3 Lluis Sanchez 2017-05-18 16:48:15 UTC
This is a crash in the compiler.
Comment 4 Marek Safar 2017-05-26 16:37:55 UTC

*** This bug has been marked as a duplicate of bug 56246 ***