Bug 56119 - Packages produced by new bockbuild report mscorlib.dll not found
Summary: Packages produced by new bockbuild report mscorlib.dll not found
Status: RESOLVED FIXED
Alias: None
Product: Installers
Classification: Mono
Component: macOS Installer ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Alexis Christoforides
URL:
: 56930 ()
Depends on:
Blocks:
 
Reported: 2017-05-08 23:19 UTC by Alexander Köplinger [MSFT]
Modified: 2017-05-31 11:15 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: before the new bockbuild

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alexander Köplinger [MSFT] 2017-05-08 23:19:31 UTC
Reproduced using Mono JIT compiler version 5.3.0.295 (master/608fbb2 Fri May  5 11:04:29 EDT 2017)

> $ mono /Library/Frameworks/Mono.framework/Versions/5.3.0/lib/mono/4.5/mcs.exe
> The assembly mscorlib.dll was not found or could not be loaded.
> It should have been installed in the `/Users/builder/data/lanes/2716/mono-mac-sdk/external/bockbuild/stage/lib/mono/4.5/mscorlib.dll' directory.
Comment 1 Alexander Köplinger [MSFT] 2017-05-08 23:38:16 UTC
The wrong path is in the mod-mono-server wrapper script too:

> $ cat /Library/Frameworks/Mono.framework/Versions/5.3.0/bin/mod-mono-server
> #!/bin/sh
> exec /Users/builder/data/lanes/2716/mono-mac-sdk/external/bockbuild/stage/bin/mono $MONO_OPTIONS "/Users/builder/data/lanes/2716/mono-mac-sdk/external/bockbuild/stage/lib/mono/4.5/mod-mono-server2.exe" "$@
Comment 2 Alexis Christoforides 2017-05-18 18:23:45 UTC
I am working on this, but the packages produced locally do have the scripts correctly relocated. Doing some more tracing.
Comment 3 Alexander Köplinger [MSFT] 2017-05-31 10:32:33 UTC
This is fixed now, thanks!
Comment 4 Alexander Köplinger [MSFT] 2017-05-31 11:15:16 UTC
*** Bug 56930 has been marked as a duplicate of this bug. ***