Bug 5609 - Cannot add layout files to other resources folders in MD as directed by Fragments Walkthrough
Summary: Cannot add layout files to other resources folders in MD as directed by Fragm...
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 4.2.x
Hardware: PC Mac OS
: --- major
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2012-06-11 12:32 UTC by PJ
Modified: 2012-07-23 06:43 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description PJ 2012-06-11 12:32:08 UTC
While following:

http://docs.xamarin.com/android/tutorials/Fragments_Walkthrough/Part_1_-_Walkthrough

you cannot execute step 3 using MonoDevelop on Windows 7.

Simple test case:
Start new MFA solution.
Add a new folder under Resources, call it Layout-large (or layout-large)
Add a file to this new folder (right click folder->Add new file)

Expected:
New file is added to the new folder.

Actual:
New file is added to the main layout folder.



Workaround attempt steps:
Drag the new file to the layout-large folder

Expected:
File should move to the new folder

Actual:
https://gist.github.com/2910749


Entire sequence:
http://screencast.com/t/zUylOStfJyX

Correct behavior (Visual Studio): http://screencast.com/t/gIWCFISGDp

Attempts with other filenames, etc (for one file it worked fine, however several failed): http://screencast.com/t/XMulBAmE2f




Seen on:

MD 3.0.3.1 (beta)
MFA 4.2.3 (beta)
Mono 2.10.9_11
Comment 1 Mikayla Hutchinson [MSFT] 2012-07-10 19:10:12 UTC
I investigated a bit, this seems to be part of the designer.
Comment 2 Lluis Sanchez 2012-07-23 06:43:26 UTC
Fixed in master.