Bug 5600 - top level TableLayout causes NullReferenceException on VS2010
Summary: top level TableLayout causes NullReferenceException on VS2010
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 4.2.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Eric Maupin
URL:
Depends on:
Blocks:
 
Reported: 2012-06-10 12:54 UTC by Atsushi Eno
Modified: 2012-06-13 12:04 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Atsushi Eno 2012-06-10 12:54:45 UTC
This reproduces only on VS 2010. MonoDevelop does not reproduce it.

Create a new layout, delete the default LinearLayout, then drag and drop TableLayout from toolbox. It shows "The layout could not be loaded: Object reference not set to an instance of an object." message on the designer.

Tested on 4.2.3 beta.
Comment 1 Lluis Sanchez 2012-06-13 11:01:54 UTC
This is caused by a NRE in TreeViewBackend. Eric, can you take a look at this?
Comment 2 Eric Maupin 2012-06-13 12:04:46 UTC
Fixed in XWT edea10667e