Bug 55961 - Cannot binding Text or any type if use nameof(reference) in Path. it won't work in XAML too.
Summary: Cannot binding Text or any type if use nameof(reference) in Path. it won't w...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jimmy [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-05-04 13:56 UTC by Muhammad Yunus
Modified: 2017-05-06 06:34 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Muhammad Yunus 2017-05-04 13:56:08 UTC
If I use below code it won't work :

     Markdown.SetBinding(MarkdownTextView.MarkdownProperty, new Binding(nameof(ViewModel.MarkdownText)));
     Markdown.SetBinding(Label.FontSizeProperty, new Binding(ViewModel.MarkdownText)));

But if I use below code, it will work:
    Markdown.SetBinding(MarkdownTextView.MarkdownProperty, new Binding("MarkdownText"));
    Markdown.SetBinding(Label.FontSizeProperty, new Binding("MarkdownText"));

I experience this on Android, but in Windows no problem. I think I am gonna stick with the second one. but I hope Xamarin's team will fix this, because I need C# 6 feature to work.

Thanks guy. sorry for bad english.
Comment 1 Jimmy [MSFT] 2017-05-05 17:00:28 UTC
Thank you for filing this report! I did not experience any issues when I tested this with a new project.

Can you give more details about what is not working? Is the app crashing? What version of Xamarin.Forms are you experiencing this on? Can you attach a project that reproduces the issue so we can continue looking into this?

When providing the requested information, please set the report's status back to NEW otherwise we may close this issue after 30 days of no response. Thanks!
Comment 2 Muhammad Yunus 2017-05-06 06:34:17 UTC
I think it was fixed, i try to update Xamarin version to the pre release and it back to normal. i don't know why, but know i am glad to have xamarin.forms pre version. more faster, i think. looking forward to the stable release xamarin.forms 2.3.5. Thanks.