Bug 55637 - Unable to build C projects with error Target named 'Clean' not found in the project. (Same goes for 'Build')
Summary: Unable to build C projects with error Target named 'Clean' not found in the p...
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: 4.8.0 (C9)
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-04-26 16:45 UTC by Phil_K97
Modified: 2018-03-15 10:40 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Phil_K97 2017-04-26 16:45:27 UTC
We have a solution containing both C# and C Projects.

The C Project was added today and while MonoDevelop builds everything correctly the xbuild Foo.sln /t:Clean fails with error 'Target named 'Clean' not found in the project.

I think the Project File is not created correctly, but can't really verify it.

For the moment we can build everything but not with cleaning beforehand, which would be really nice to have.

I've already checked Bug 43356, which seems like my problem but I didn't change the interface language. Note that my Monodevelop is in german though.
Comment 1 Phil_K97 2017-04-26 16:57:43 UTC
EDIT:

The same error message appears for xbuild Foo.sln /t:Build so we're currently unable to build!
Comment 2 Marek Safar 2018-03-15 10:40:06 UTC
We deprecated xbuild and recommend using msbuild instead. Switching to msbuild will also most likely resolve the issue you reported.