Bug 5557 - Portable Library project type no longer recognized
Summary: Portable Library project type no longer recognized
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2012-06-06 18:47 UTC by jacobf
Modified: 2015-08-20 14:00 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description jacobf 2012-06-06 18:47:26 UTC
After installing the Mono for Android Addin, the Portable Library (C#) project type no longer loads.  This is ironic, as this is precisely why I installed the Android add-in-- to see if I could reference this portable assembly.

Here is the error text:
Could not load project '/Users/----/MonoProjects/Testing/MyPortableLibrary/MyPortableLibrary.csproj' with unknown item type '{786C830F-07A1-408B-BD7F-6EE04809D6DB};{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}'

Also, the Portable Library option is now gone from the Add Project dialog.

MonoDevelop 3.0.2
Monotouch: 5.2.12
Mono for Android: 4.2.2.134493563 (Evaluation)
Comment 1 jacobf 2012-06-06 19:05:35 UTC
FYI, I restarted my machine and the issue is gone.
Comment 2 Mikayla Hutchinson [MSFT] 2012-06-06 21:18:05 UTC
Possibly a random addin engine issue.