Bug 55521 - [IBTool] : An item with the same key has already been added.
Summary: [IBTool] : An item with the same key has already been added.
Status: RESOLVED DUPLICATE of bug 54914
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: XI 10.8 (d15-1)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-04-24 14:38 UTC by Jean-Marie Gueirard
Modified: 2017-04-25 15:16 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
build server config (1.87 KB, text/plain)
2017-04-24 14:38 UTC, Jean-Marie Gueirard
Details
My mac config (1.95 KB, text/plain)
2017-04-24 14:39 UTC, Jean-Marie Gueirard
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 54914

Description Jean-Marie Gueirard 2017-04-24 14:38:43 UTC
Created attachment 21734 [details]
build server config

Hi,

We are currently facing an issue with IBtool returning this error
It's probably a duplicate from https://bugzilla.xamarin.com/show_bug.cgi?id=51289, but I cannot reopen it.

This is the build output when failing: https://gist.github.com/jmgueirard/dc42dbd5eec7a863860516a287abd7c3
And the build output when succeding: https://gist.github.com/jmgueirard/68a7db433c33bc64d1a46e304d6362cb

The problem seems to be in name resolution, we have a lot of xib files with ~ipad in it. Removing this file make the IBTool task stable again.

I created a repo here: https://github.com/jmgueirard/MartialApp/tree/IBtool-bug

I uploaded my MacBook config(
Comment 1 Jean-Marie Gueirard 2017-04-24 14:39:23 UTC
Created attachment 21735 [details]
My mac config
Comment 2 Jean-Marie Gueirard 2017-04-24 14:43:04 UTC
I uploaded my mac book config where the build is not working currently,
and our build server config where it's working as it's using an older version of xamarin iOS.

ps: sorry for the multiple comments
Comment 3 Juan Colo 2017-04-25 14:47:52 UTC
I had this same problem.
The jstedfast commit (https://github.com/xamarin/xamarin-macios/commit/f6ebca8ca9d056831aa5d093fb48aab0c0293934) fixes this issue.
Comment 4 Alex Soto [MSFT] 2017-04-25 15:06:25 UTC
This should be fixed in our next major release called 15.2

You can follow the release progress in our release blog @ https://releases.xamarin.com

*** This bug has been marked as a duplicate of bug 54914 ***
Comment 5 Jean-Marie Gueirard 2017-04-25 15:16:44 UTC
Thanks for the info :)