Bug 55514 - Breakpoint is not working on remoted iOS Stimulator for VS 2017
Summary: Breakpoint is not working on remoted iOS Stimulator for VS 2017
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-04-24 12:14 UTC by Saurabh Paunikar
Modified: 2017-05-18 13:43 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Attached are the log generated during Execution (4.73 KB, application/zip)
2017-04-24 12:14 UTC, Saurabh Paunikar
Details
Attached are the Xamarin.Stimulator_log(Windows) (1.12 KB, text/plain)
2017-04-25 07:08 UTC, Saurabh Paunikar
Details
Attached are the log of Simulator.Server(From MAC Agent) (690.51 KB, text/plain)
2017-04-25 07:11 UTC, Saurabh Paunikar
Details
IDE and Simulator logs (1.12 MB, application/x-zip-compressed)
2017-05-03 12:50 UTC, Swati Gangrade
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Saurabh Paunikar 2017-04-24 12:14:15 UTC
Created attachment 21726 [details]
Attached are the log generated during Execution

Steps to Reproduce

1.Launch Visual Studio-2017
2.Create a Xamarin.Forms portable sample
3.Add breakpoints in AppDelegate.CS file
4.Deploy application in Remoted iOS Stimulator

Actual Result:Application Launches but Breakpoint are not hitted.
Expected Result:Breakpoint should get hitted

Build info:

https://gist.github.com/saurabh-paunikar/7ca821731aad92b6ec87510f705212ed

ScreenCast: https://www.screencast.com/t/XlVakdn7taac
Comment 1 Ben Beckley 2017-04-24 20:32:19 UTC
I am not able to reproduce this using 
XVS 4.5.0.415 (6caf703/d15-2)
Remote Simulator 1.0.2.9 (0435c36)
VS2017 15.2 26419.1 d15rel Preview 2

@Saurabh, please include the simulator logs from your Mac Agent and Windows machines.

>~/Library/Logs/Xamarin/Simulator.Server/
>C:\Users\bebeckle\AppData\Local\Xamarin\Logs\Xamarin.Simulator

env info: https://gist.github.com/BenBeckley/d5ffea01032b83204e3d60e7db5a1130
Comment 2 Saurabh Paunikar 2017-04-25 07:08:25 UTC
Created attachment 21740 [details]
Attached are the Xamarin.Stimulator_log(Windows)

Stimulator Version : 1.0.2.9
Comment 3 Saurabh Paunikar 2017-04-25 07:11:23 UTC
Created attachment 21741 [details]
Attached are the log of Simulator.Server(From MAC Agent)
Comment 4 Saurabh Paunikar 2017-04-25 07:14:09 UTC
@Ben I have provided mentioned details. Changing defect Status to NEW again
Comment 5 Swati Gangrade 2017-05-03 12:49:10 UTC
For Xcode 8.1 I am facing this Issue where as for XCode 8.3.2 it works perfect.

Environment info : https://gist.github.com/gangrade-swati/0f553e2ec195bae3686491a5bac6ab1a

Screencast : http://www.screencast.com/t/yVvWZYmw1dTO

Attaching IDE and Simulator logs.
Comment 6 Swati Gangrade 2017-05-03 12:50:11 UTC
Created attachment 21919 [details]
IDE and Simulator logs
Comment 7 vga 2017-05-18 13:43:46 UTC
We weren't able to repro this. Please feel free to re-open if you are still facing this with latest Xamarin bits. Thanks.