Bug 55481 - Bad code generation for function without parameter
Summary: Bad code generation for function without parameter
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: Bindings ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Atsushi Eno
URL:
Depends on:
Blocks:
 
Reported: 2017-04-22 07:01 UTC by engshun.lim
Modified: 2017-08-23 21:07 UTC (History)
2 users (show)

Tags: bb
Is this bug a regression?: ---
Last known good build:


Attachments
bad code (40.53 KB, image/png)
2017-04-22 07:01 UTC, engshun.lim
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description engshun.lim 2017-04-22 07:01:05 UTC
Created attachment 21717 [details]
bad code

com.beardedhen.androidbootstrap.font.IconSet#fontPath() be generated to Com.Beardedhen.Androidbootstrap.Font.IIconSetExtensions(this Com.Beardedhen.Androidbootstrap.Font.IIconSet self, ) <-- A comma is there which cause syntax error
Comment 1 Mark McLemore 2017-06-23 18:47:33 UTC
Hi, can you attach some additional information to help us reproduce this error (ideally, a test case)?  This topic provides some useful guidelines: https://developer.xamarin.com/guides/cross-platform/troubleshooting/questions/howto-file-bug/

Thanks!
Comment 2 Cody Beyer (MSFT) 2017-08-23 21:07:14 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!