Bug 5544 - Wierd paste characters
Summary: Wierd paste characters
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-06-06 03:31 UTC by Stephan Coertzen
Modified: 2012-06-13 04:25 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Copy paste issue (864.61 KB, image/jpeg)
2012-06-06 03:31 UTC, Stephan Coertzen
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Stephan Coertzen 2012-06-06 03:31:38 UTC
Created attachment 2022 [details]
Copy paste issue

Description of Problem:
When I copy paste code in the C# code editor in pastes weird characters.

Steps to reproduce the problem:
1. Open C# code file
2. Copy any variable
3. Paste and get weird characters


Actual Results:
See attachment

Expected Results:
Copy text that I've highlighted

How often does this happen? 
Usually after the second copy paste or third copy paste action.

Additional Information:
Comment 1 Mike Krüger 2012-06-06 04:16:56 UTC
Which monodevelop version ?
Comment 2 Stephan Coertzen 2012-06-06 04:17:46 UTC
3.0.2
Comment 3 Mike Krüger 2012-06-07 03:00:47 UTC
I can't repro it on windows 7 - it may be a side effect from another application.

Can you try to get gedit for windows:

http://ftp.gnome.org/pub/gnome/binaries/win32/gedit/2.30/

Do you have the same problem there ?
Comment 4 Mike Krüger 2012-06-13 04:25:22 UTC
I can't verify the issue on my win 7. I assume that something interferes with the gtk clipboard on your system. Would've been nice to test gedit as well.