Bug 55438 - Xamarin Studio stops opening solutions to last state
Summary: Xamarin Studio stops opening solutions to last state
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 6.3 (15.1)
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-04-20 21:21 UTC by Rod Barnes
Modified: 2017-07-17 18:53 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
IDE log (10.28 KB, text/plain)
2017-04-20 21:21 UTC, Rod Barnes
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Rod Barnes 2017-04-20 21:21:18 UTC
Created attachment 21667 [details]
IDE log

Normally, XS opens a solution and shows the last state it was in when last opened; e.g., modules are open which were opened, left-hand solution tree nodes are expanded or collapsed as they were when last opened, etc.

Just a minute ago, it stopped do that.  I've been switching between two different solutions as I am modifying one based upon things I had implemented in the other.  I would open one, make a change and save it, go to "File > Recent Solutions" and select the other solution to open.  I'd review some aspect of this solution (making no changes) and then go to "File > Recent Solutions" to open the original solution again to make a change.

At one point, it just opened the solution as though it had never been opened: solution tree nodes were all collapsed, no modules were open in the editor.

I closed and quit XS and then re-opened it and it is back to working correctly.  I expect this was an anomaly but have attached the most recent IDE log regardless.  If it happens again, I will update this case.
Comment 1 Jason Imison 2017-04-24 10:43:00 UTC
I'm not able to reproduce this, and your logs don't contain anything unusual. Changing status to NEEDINFO. 

Please update this ticket if you manage to repro again. Thanks for the report.
Comment 2 Rod Barnes 2017-05-11 16:51:00 UTC
I've had it happen again.  I've yet to identify any particular pattern.  No new info beyond that in the original report.
Comment 3 Jordan Matthiesen [MSFT] 2017-07-17 18:53:49 UTC
Hi, Rod! Thanks for taking the time to submit this report! I attempted to reproduce this issue based on the bug description with the latest Visual Studio 2017 for Mac Preview version 7.1, and I was unable to hit the problem. I see that the issue keeps happening for you and I'll keep an eye out to see if I can eventually get a solid set of repro steps. If this issue occurs again for you, and you can identify a pattern, please reopen this report and attach the  reproduction, ideally starting with a new template project and then showing the smallest number of steps needed to create the issue.