Bug 55058 - Button inside ListView.ItemTemplate disappearing if Text property is changed.
Summary: Button inside ListView.ItemTemplate disappearing if Text property is changed.
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-04-12 08:24 UTC by dpedrinha
Modified: 2017-04-12 14:34 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description dpedrinha 2017-04-12 08:24:03 UTC
So I had this same bug a while ago that made me forget about Xamarin. Well, after quite a few months the bug was marked as FIXED and a few months later I decided to come back to this project.

Turns out the bug disappeared the same way any Text property inside an ItemTemplate does when any property is changed.

You gotta be kidding me. You said this bug was fixed more than 6 months ago. And it isn't. This is a basic behavior for many apps and you can't make it work? And even the bug disappeared???? Why? This is really frustrating.

I'm attaching a test project link to test it. But to replicate the problem it's simple.
1 - Create a ListView with an ItemTemplate that has a Button inside a StackLayout (you can also add a label, it will disappear too no matter if you changed just the button).
2 - Populate the ListView
3 - Change the Button.Text property any way you want. In my case I'm doing it via Command in the ViewModel.
Result on UWP = Button will disappear. Since this is still happening I won't waste my time with Xamarin so sorry, but I can't test it on other platforms.

The test project is updated with lates Xamarin.Forms 2.3.4. And the problem is actually worse than before. Eventually the views would appear again if something changed, now they just disappear forever.

https://www.dropbox.com/s/b7rwzdw9njbmbkm/AppWithLabelsDisappearing.zip?dl=0
Comment 1 Paul DiPietro [MSFT] 2017-04-12 14:34:17 UTC
This is fixed on 2.3.5-pre1 which should soon be released. I assume you're referring to the issue fixed by https://github.com/xamarin/Xamarin.Forms/pull/731; that PR refers to a bug which you apparently commented on (https://bugzilla.xamarin.com/show_bug.cgi?id=47701), after it was stated that the issue was to be fixed in 2.3.5-pre1, not 2.3.4.

I have explicitly tested the app against the nightly build which includes that fix, as it is built against master, and the text no longer disappears.