Bug 55020 - [VS2013/15/17 15.2]Unable to hit Breakpoint while debugging iOS application
Summary: [VS2013/15/17 15.2]Unable to hit Breakpoint while debugging iOS application
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: Highest critical
Target Milestone: 15.2
Assignee: Joaquin Jares
URL:
Depends on:
Blocks:
 
Reported: 2017-04-11 11:53 UTC by Saurabh Paunikar
Modified: 2017-04-19 15:24 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build:


Attachments
Attached are the logs generated during defect reproduction (6.61 KB, application/x-zip-compressed)
2017-04-11 11:53 UTC, Saurabh Paunikar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Saurabh Paunikar 2017-04-11 11:53:07 UTC
Created attachment 21431 [details]
Attached are the logs generated during defect reproduction

Summary: When we run iOS application is Debug mode by adding breakpoint in desired position.Application runs properly but breakpoint does not hit and stop at that position.

Steps: 
1.Open Visual Studio.
2.Create a iOS solution
3.Add breakpoint to desired position
4.Run application in debug mode

Expected Result: Breakpoint should hit and debugger should stop on the breakpoint.

Actual Result: Application is running successfully without hitting breakpoint.

Note:This Bug is reproducible in WatchOS and TvOS

Build info:  https://gist.github.com/chiranjibmukherjee/fbd884cc11e285d93bb587b36edf8979

Screencast Link: https://www.screencast.com/t/d6yiWpZV
Comment 1 Sebastien Pouliot 2017-04-11 15:19:02 UTC
@Saurabh is this reproducible from a Mac (with Xamarin Studio) ? or only in VS ?

If the later then the bug needs to be assigned to "Visual Studio Extensions".
Comment 2 Saurabh Paunikar 2017-04-12 04:47:17 UTC
@Sebastien I observe this issue only on VS.Changing product to "Visual Studio Extensions"
Comment 3 Jose Gallardo 2017-04-18 12:49:11 UTC
Fixed on 
d15-2: 
XVS 4.5.0.387 (1585aad2641c69fde20893c35e1a39b31d44b1a1)

master:
XVS 4.5.0.403 (baf7aa5b11ddb96d2e6d098dc78366c3c27ba0c7)
Comment 4 Ben Beckley 2017-04-19 15:24:23 UTC
Verified the fix using 4.5.0.387 (1585aad/d15-2) - I am able to hit breakpoints in VS2013/15/17 now.