Bug 54803 - Allow debugger to attach to an already running Xamarin process
Summary: Allow debugger to attach to an already running Xamarin process
Status: RESOLVED ANSWERED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 4.4.0 (15.1)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Joaquin Jares
URL:
Depends on:
Blocks:
 
Reported: 2017-04-07 20:43 UTC by Jeremy Kolb
Modified: 2017-05-18 13:42 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Jeremy Kolb 2017-04-07 20:43:14 UTC
A few times I've wanted to attach my debugger to an existing process on the phone.  This would be really useful.
Comment 1 Jose Gallardo 2017-05-18 13:42:20 UTC
Hi Jeremy

This is actually a feature request more than a bug. We have it already in our backlog and it was discussed several times but as it requires some deep/risky changes, was not implemented yet. 

Thanks for your feedback