Bug 54792 - [VS-PropPage] Use LLVM Optimizing Compiler should only be selectable when AOT Compilation is enabled
Summary: [VS-PropPage] Use LLVM Optimizing Compiler should only be selectable when AOT...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.2
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-04-07 18:10 UTC by Ben Beckley
Modified: 2017-04-21 12:47 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Verification Screenshot (70.67 KB, image/png)
2017-04-21 12:43 UTC, Alok Kulkarni
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Ben Beckley 2017-04-07 18:10:03 UTC
Tested with XVS 4.5.0.322 (43f3cba)
This is a VSfM parity issue
Affects VS2013 and VS2015

Reproduction Steps:
1) Create/open Android app
2) Go to project properties > Android options
Expected: Use LLVM Optimizing Compiler should only be selectable when AOT Compilation is enabled
Actual: Use LLVM Optimizing Compiler is selectable when AOT Compilation is disabled. Csproj file is changed when the Use LLVM property is enabled in the page.
https://www.screencast.com/t/vkOpkPVnbu

env info: https://gist.github.com/BenBeckley/fdb4ba8ffab56c7a4027344eb8b558ea
Comment 2 Neha Kharbade 2017-04-13 06:52:20 UTC
@Juan - For both commits i.e. master & d15-2 , builds seems to be failed , kindly provide successful build commits for verification of this bug.
Comment 3 Alok Kulkarni 2017-04-21 12:43:05 UTC
Created attachment 21696 [details]
Verification Screenshot

Verified fixed on following build.
Build Info : https://gist.github.com/aman-daharwal/67d189faf51e529f8e5e1511938d1086