Bug 54649 - Navigation page title bar disappears upon navigating through tabs in (UWP)
Summary: Navigation page title bar disappears upon navigating through tabs in (UWP)
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.3.4
Hardware: PC Windows
: --- critical
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-04-06 15:10 UTC by Daryl
Modified: 2017-05-05 11:54 UTC (History)
6 users (show)

Tags: uwp, tabbedpage, navigationpage, navbar ac
Is this bug a regression?: ---
Last known good build:


Attachments
repro project (293.49 KB, application/x-zip-compressed)
2017-04-06 21:18 UTC, Jimmy [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Daryl 2017-04-06 15:10:56 UTC
# Steps to reproduce

Make a tabbed page with (x) amount of tabs in. 
Each tabbed call calls a page of its own, with a navigation page wrapped around it
One of those pages has a webview inside it with some html content

# Expected behavior
The nav/title bar should be present when all pages are selected, and all contents should render as expected 

# Actual behavior
Click through each of the tabs, upon revisiting one of the tabs previously clicked, the title/nav bar disappears as though you are not in a navigation page, and the webview does not render the content when revisited

# Supplemental info (logs, images, videos)
This has been logged in bugzilla before I think, but was resolved/fixed. I can't seem to find it at the moment but it is also described here:
https://forums.xamarin.com/discussion/70744/xamarin-forms-uwp-navigationpage-issue

# Test environment (full version information)
Visual studio 2015 community
Xamarin forms v2.3.4.224
Comment 1 Jimmy [MSFT] 2017-04-06 21:18:08 UTC
Created attachment 21282 [details]
repro project

I believe I'm able to reproduce this issue. I am attaching a repro project to the report.

### Steps to Reproduce
1. Run the attached UWP project
2. Go through each tab to get to Tab 4
3. Go back to Tab 3 or another tab


### Expected Results
The Page title will be visible in the nav bar.


### Actual Results
The page titles for the previous tabs are not visible anymore.


### Version Test
2.3.5.84    BAD
2.3.4.224   BAD
2.3.3.193   BAD
Comment 2 Daryl 2017-04-07 09:18:41 UTC
Thanks for this - I didn't end up having time at the end of the day to do this, so you've saved me the trouble. 

NB - the point I made about the webview is a red herring and a separate issue of my own, so please ignore. The title bar issue is the sole problem here.
Comment 3 Samantha Houts [MSFT] 2017-05-04 18:23:35 UTC
https://github.com/xamarin/Xamarin.Forms/pull/901
Comment 4 Rui Marinho 2017-05-05 11:54:39 UTC
Should be fixed on 2.3.6-pre1