Bug 5447 - MonoTests.System.Net.HttpBasicAuthScheme Fail
Summary: MonoTests.System.Net.HttpBasicAuthScheme Fail
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Gonzalo Paniagua Javier
URL:
Depends on:
Blocks:
 
Reported: 2012-06-01 00:25 UTC by Vinicius Jarina
Modified: 2012-06-01 21:06 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Vinicius Jarina 2012-06-01 00:25:10 UTC
Response:

HTTP/1.1 400 Bad Request
Content-Type: text/html; charset=utf-8
Server: Mono-HTTPAPI/1.0
Date: Fri, 01 Jun 2012 04:01:01 GMT
Content-Length: 35
Connection: close

<h1>Bad Request (Invalid host)</h1>

Expected:

HTTP/1.1 401 Unauthorized
WWW-Authenticate: Basic realm=""
Server: Mono-HTTPAPI/1.0
Date: Fri, 01 Jun 2012 04:24:22 GMT
Content-Length: 0
Connection: close