Bug 5441 - Partial class for action connection disappears from .designer file after project upgrade and new outlet
Summary: Partial class for action connection disappears from .designer file after proj...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 3.0.x
Hardware: Other Other
: --- blocker
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
: 5627 ()
Depends on:
Blocks:
 
Reported: 2012-05-31 13:13 UTC by Mike Bluestein
Modified: 2012-06-13 11:53 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mike Bluestein 2012-05-31 13:13:47 UTC
Description of Problem:

When migrating an old monotouch project with a xib that contained outlets and an action, the partial class for the action is not present in the .designer file after adding a new outlet.

Steps to reproduce the problem:

1. Open an old project and select migrate.
1. Open a xib has an outlet and an action connected to xib's controls. 
2. Add a new UILabel and connect an outlet.
3. Check the .designer file, the partial class is missing.

Actual Results:

Partial class missing for action.

Expected Results:

Partial class should be present.

How often does this happen?

Always.

Additional Information:

I was able to repro it with both the latest stable (3.0.2) and master (https://wrench.internalx.com/Wrench/ViewLane.aspx?lane_id=84&host_id=1&revision_id=31711)

The project I'm using as a test case is LMT2-2 available from my github account here: https://github.com/mikebluestein/learning_monotouch_code/tree/master/ch2/LMT2-2

Here is a screenshot showing before and after of the .designer file: http://screencast.com/t/dppAx8ommPb7
Comment 1 Mike Krüger 2012-06-01 01:53:32 UTC
*** Bug 5430 has been marked as a duplicate of this bug. ***
Comment 2 Mike Krüger 2012-06-01 02:16:10 UTC
fixed.
Comment 3 Jeffrey Stedfast 2012-06-13 11:53:39 UTC
*** Bug 5627 has been marked as a duplicate of this bug. ***