Bug 54307 - FileNotFound for MasterDetail>Native>Shared Xplat template causing build failure
Summary: FileNotFound for MasterDetail>Native>Shared Xplat template causing build failure
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Templates ()
Version: 4.4.0 (15.1)
Hardware: PC Windows
: --- critical
Target Milestone: 15.2
Assignee: Pierce Boggan [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-03-30 20:45 UTC by Ben Beckley
Modified: 2017-04-28 20:07 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Ben Beckley 2017-03-30 20:45:18 UTC
XVS 4.4.0.33 (80d9a02)
VS2017 26328.55 d15rel PR
XF.Templates 0.5.285

Reproduction Steps:
1) Start VS2017
2) Select File > New > Project
3) Create a new Cross-Platform "Master Detail>Native>Shared" app
4) Connect to Mac agent
5) Build iOS project
Expected: iOS project builds successfully
Actual: Get the error below:

>File not found: /Users/Ben/Library/Caches/Xamarin/mtbs/builds/App2.iOS/9f1fafef6d5e2818b6952d2173bb569a/Assets.xcassets/AppIcon.appiconset/Icon-Small-40.png

There is an Icon-Small-40@2x.png but no Icon-Small-40.png
https://www.screencast.com/t/UJcpife2kB0C

env info: https://gist.github.com/BenBeckley/8bab689e941b781958ed5f3b708220de
Comment 2 Ben Beckley 2017-04-27 20:24:30 UTC
Verified the fix with 0.5.483 from comment 1.

Unfortunately, I am now hitting this error:
https://gist.github.com/BenBeckley/669c18f67354c9baa240e6899ffb37c1

env info: https://gist.github.com/BenBeckley/124c07b8141f6f56c0a29df1a281f3fc
Comment 4 Ben Beckley 2017-04-28 20:07:43 UTC
Verified the fix from comment 3 using duplo-templates 0.5.484 (b514d55/duplo-templates-d15-2).

I am no longer getting errors where files are not being found.

env info: https://gist.github.com/BenBeckley/7e7985eef4f2d91dbae9adee02c4f320