Bug 5428 - Creating a new MonoMac Project in MonoDevelop 3.0.2 wont quit after "start program without debugging"
Summary: Creating a new MonoMac Project in MonoDevelop 3.0.2 wont quit after "start pr...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
: 5574 ()
Depends on:
Blocks:
 
Reported: 2012-05-31 00:49 UTC by Jeronimo Colon III
Modified: 2012-06-15 21:17 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jeronimo Colon III 2012-05-31 00:49:46 UTC
1. Update to the latest version of MonoDevelop (at the time of this writting it's 3.0.2).
2. Update to the latest SDK (at the time of this writing it's 2.10.9).
3. Start New Solution
4. Select "MonoMac Project"
5. Click "Start program without debugging"
6. Hold down Command and press Q - or - Select the name of the application from the menu and select "Quit"

I've followed these step on my Snow Leopard Macbook Pro with an older version of XCode (version information included below) and on my Lion iMac with the latest version of XCode with the same results.

From Macbook Pro:
MonoDevelop 3.0.2
Installation UUID: aad14cea-1e23-4ad4-b82c-e1b78905053f
Runtime:
	Mono 2.10.9 (tarball Mon May  7 20:25:51 EDT 2012)
	GTK 2.24.10
	GTK# (2.12.0.0)
	Package version: 210090011
Apple Developer Tools:
	 Xcode 4.0.2 (99)
	 Build 4A2002a
Mono for Android not installed
Monotouch: 
Build information:
	Release ID: 30002000
	Git revision: 046db1bb0d9d438aa4d3468d66c6f963bc44c51a-dirty
	Build date: 2012-05-23 21:39:54+0000
	Xamarin addins: d99a1741642a336943d5607bdc1a09efa2ac3b86
Operating System:
	Mac OS X 10.6.8
	Darwin new-host-5.home 10.8.0 Darwin Kernel Version 10.8.0
	    Tue Jun  7 16:32:41 PDT 2011
	    root:xnu-1504.15.3~1/RELEASE_X86_64 x86_64


Thanks.
Comment 1 Jeffrey Stedfast 2012-06-04 11:56:30 UTC
Thanks for the bug report!

This is now fixed in git master.

The problem was that "MainMenu" was not being set as the NSMainNibFile in the Info.plist.
Comment 2 Mikayla Hutchinson [MSFT] 2012-06-15 21:17:03 UTC
*** Bug 5574 has been marked as a duplicate of this bug. ***