Bug 54226 - Visual studio mac connection disconnects when you lock screen
Summary: Visual studio mac connection disconnects when you lock screen
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Windows
: Normal enhancement
Target Milestone: 15.4
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-29 14:53 UTC by Denys Han
Modified: 2017-07-27 12:16 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Attached IDE logs (3.72 KB, application/x-zip-compressed)
2017-07-27 12:16 UTC, Aman Dharwal
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Denys Han 2017-03-29 14:53:08 UTC
# Steps to reproduce
Open visual studio, initiate connection to Mac, lock screen in Windows, unlock screen

# Expected behavior
Mac connection continues working

# Actual behavior
Mac connection disconnects and tries to reconnect

# Test environment (full version information
both Mac and Windows machines have stable network and internet connection during the screen lock.
ssh connection started before lock screen persists normally through lock/unlock.
Happens in VS 2015/2017/2017 Preview
Comment 1 Daniel Cazzulino 2017-04-06 19:00:27 UTC
I can confirm this is indeed the case. Even though the reconnect is automatic and quite fast in my case, it would still be nice to not disconnect unnecessarily.
Comment 2 xamarin-release-manager 2017-06-23 20:29:56 UTC
Fixed in version 4.7.0.637 (xma-refactoring)

Author: Mauro Agnoletti
Commit: a4e51330669fa3c4353513c36f08344ef5f05ef8 (xamarin/XamarinVS)
Comment 3 Aman Dharwal 2017-07-27 12:16:14 UTC
Created attachment 23846 [details]
Attached IDE logs

This issue doesn't exist anymore, hence marking it as Verified

Environment info : https://gist.github.com/gangrade-swati/a3105bc901b760cd45df8ccbfd6c6203

========================================================================

Output logs:

Xamarin :

Connecting to the Server...
Starting connection to 172.18.36.167...
Starting Broker 1.1.6.28 in port 50810...
Starting agents on 172.18.36.167 (172.18.36.167)
Starting Agent Build 4.7.0.826...
Starting Agent IDB 4.7.0.826...
Agent Build 4.7.0.826 is running
Agent IDB 4.7.0.826 is running
Connected to the Server 172.18.36.167 (172.18.36.167) with Full support.
Successfully connected to the Server!

========================================================================

Screencast link : https://www.screencast.com/t/2T5NMAQ1