Bug 5410 - AudioUnit Dispose method throws EntryPointNotFound exception
Summary: AudioUnit Dispose method throws EntryPointNotFound exception
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: 5.2
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-05-30 06:16 UTC by Mika Aalto
Modified: 2012-07-03 20:32 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Unit test case for reproducing this issue. (3.08 KB, application/x-gzip)
2012-05-30 06:16 UTC, Mika Aalto
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mika Aalto 2012-05-30 06:16:21 UTC
Created attachment 1985 [details]
Unit test case for reproducing this issue.

Every time when my code calls AudioUnit object Dispose-method, I get EntryPointNotFoundException.

Trace from debugger:
DisposeMethodTest : System.EntryPointNotFoundException : AudioUnitUnInitialize
		  at (wrapper managed-to-native) MonoTouch.AudioUnit.AudioUnit:AudioUnitUnInitialize (intptr)
		  at MonoTouch.AudioUnit.AudioUnit.Dispose (Boolean disposing) [0x0001b] in /Developer/MonoTouch/Source/monotouch/src/shared/AudioUnit/AudioUnit.cs:302 
		  at MonoTouch.AudioUnit.AudioUnit.Dispose () [0x00000] in /Developer/MonoTouch/Source/monotouch/src/shared/AudioUnit/AudioUnit.cs:291 
		  at AudioUnitDisposeTest.AudioUnitTest.DisposeMethodTest () [0x000a9] in /Users/mikaa/Projects/AudioUnitDisposeTest/AudioUnitTest.cs:43


I attached MonoTouch NUnitLite unit test case which can be used to reproduce this issue.

I am using MonoTouch version 5.2.12
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-05-30 07:10:55 UTC
Fixed.

master: 29c38a543e50509d66680c44da25fc750f2d5ea6
5.2-series: 550db9f6cc3339429919ca783e856fdf3f0b2ebe

The next releases with this fix will be 5.2.13 and 5.3.5, but if you need it I can give you a hotfix.
Comment 2 Mika Aalto 2012-05-30 07:15:36 UTC
Thank you Rolf for quick response. I have my own workaround for this issue so I have time to wait 5.2.13 release. Thanks!
Comment 3 zezba9000 2012-07-03 19:48:28 UTC
I am getting this issue using MonoTouch 5.2
Comment 4 zezba9000 2012-07-03 19:51:25 UTC
Ooops sry im using "5.2.12" and its fixed in "5.2.13"
Comment 5 zezba9000 2012-07-03 20:25:50 UTC
Actually this still seems to be broken at least in beta... I just updated to "5.3.4" and the dispose method still crashes my app.
Comment 6 Rolf Bjarne Kvinge [MSFT] 2012-07-03 20:32:00 UTC
The next beta release with this fix will be 5.3.5.

5.3.4 was already released when this was fixed.