Bug 541 - vb like operator fails to match when a '-' is used in the front of the pattern
Summary: vb like operator fails to match when a '-' is used in the front of the pattern
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: VB Runtime ()
Version: 2.10.x
Hardware: All All
: Normal major
Target Milestone: Untriaged
Assignee: Rolf Bjarne Kvinge [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2011-08-30 11:38 UTC by Dylan Borg
Modified: 2011-09-13 04:18 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 541 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Dylan Borg 2011-08-30 11:38:49 UTC
The function Microsoft.VisualBasic.CompilerServices.LikeOperator.LikeString does not confirm a match when it should do so in the case of patterns beginning with a '-' meant to match the latter character.

The bug was observed when the following parameters were passed:
1. "-1d"
2. "-#*"
3. OptionCompare.Binary

The Microsoft version of the Microsoft.VisualBasic.dll library does not exhibit this bug in the before mentioned function. While the Mono version does have the bug. The mentioned parameters should yield True while when I tried this with Mono on Windows and Linux (Mono 2.10.1) it gave out False.