Bug 53894 - [VS2015-Win10][Build XVS 99.1.0.872]-Unable to enable the indirect rendering feature even when having enabler file.
Summary: [VS2015-Win10][Build XVS 99.1.0.872]-Unable to enable the indirect rendering ...
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 7.1 (C9)
Hardware: PC Windows
: --- critical
Target Milestone: ---
Assignee: Jérémie Laval
URL:
Depends on:
Blocks:
 
Reported: 2017-03-24 11:25 UTC by Gaurav Ganorkar
Modified: 2017-05-23 10:20 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Attached DesgnerLogs and EnablerFile screenshot (22.09 KB, application/x-rar)
2017-03-24 11:25 UTC, Gaurav Ganorkar
Details
Exception in logs for rendering (181.35 KB, application/x-zip-compressed)
2017-05-23 10:19 UTC, Gaurav Ganorkar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Gaurav Ganorkar 2017-03-24 11:25:43 UTC
Created attachment 20790 [details]
Attached DesgnerLogs and EnablerFile screenshot

----Description-----
https://trello.com/c/7SGdShS0/123-indirect-rendering-on-vs-windows

----Test Environment----
Windows 10
Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01055

Installed Version: Enterprise

Xamarin   99.1.0.872 (b9f5876)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.1.99.89 (e5b2951)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.9.0.60 (2380389)
Visual Studio extension to enable development for Xamarin.iOS.

----Precondition----
1-Before launching Visual Studio make sure to create file at location "C:\Users\[yourname]\Documents\xam-designer-useiosurface" without any extension.

----Steps To Reproduce----
1-Launch VS and Create Android Single View application 
2-Add Image in image view in main.axml
3- Add Layouts 
4-Build the Project.
5-Now Open Help>Xamarin>Logs>AndroidDesigner.txt file and Observe

----Expected Result-----
Renderer >> INFO: "indirect rendering enabled for Android designer" should be displayed in logs 

----Actual Result----
Renderer >> INFO: No indirect rendering available is displayed along with an exception 
Renderer >> ERROR: java.lang.ClassNotFoundException: mono.android.D3DImageFactory
 
-----Frequency of Reproduction----
100%

----Supplemental Information----
Attached Android designer log files for the build on to which this feature is broken also attached screenshot of the enabler file

----ScreenCast Link----
https://www.screencast.com/t/yynyvmUbh
Comment 1 Jérémie Laval 2017-04-03 21:03:07 UTC
We (finally) have a build of the latest master with indirect rendering. Please re-test using latest commit of the android-designer-indirectrendering branch (26a22ef5).

PS: please use zip instead of rar when attaching logs as it's the most universal format to decompress.
Comment 2 Gaurav Ganorkar 2017-04-07 09:54:47 UTC
jeremie , all the successive builds after the commit id (26a22ef5) is appearing to be failed on the wrench  "https://wrench.internalx.com/Wrench/index.aspx?lane=xvs-win-android-designer-indirectrendering"


Error Message
<Error>
<Code>BlobNotFound</Code>
<Message>
The specified blob does not exist. RequestId:0adaeb8b-0001-00d0-0883-af74ed000000 Time:2017-04-07T09:43:17.8084940Z
</Message>
</Error>

LANE-
Build of revision 26a22ef5083583a68657892a5129a0bec8e35c74 on lane 'xvs-win-android-designer-indirectrendering' on 'Win10-VS' (table)

Can you please update us with the latest build to be taken ?
Comment 3 PhilippeT 2017-05-19 16:39:08 UTC
Hi, this bug may be related to https://forums.xamarin.com/discussion/95783/classnotfoundexception-when-rendering-axml-file. If you need more informations... good luck.
Comment 4 Gaurav Ganorkar 2017-05-23 10:19:53 UTC
Created attachment 22383 [details]
Exception in logs for rendering

Verified this issue on VS 2015  Xamarin   4.5.0.425 (102e226) 

 Build link - https://bosstoragemirror.blob.core.windows.net/wrench/xvs-win-android-designer-indirectrendering/10/102e226386618b2c11a87530

We are able to see the indirect rendering enabled in the logs and Also checked deploying various imageView application which can rendered.

But we are able to see some exceptions in the logs i have attached logs for it.

Marking this defect as verified as this defect is fixed in the 4.5.0.425