Bug 53863 - 4.5-api reference assemblies don't align with .NET 4.5
Summary: 4.5-api reference assemblies don't align with .NET 4.5
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: General ()
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Alexander Köplinger [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-03-23 16:37 UTC by Jonathan Pryor
Modified: 2017-03-30 01:32 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jonathan Pryor 2017-03-23 16:37:24 UTC
Case in point, consider System.Net.SecurityProtocolType:

https://msdn.microsoft.com/en-us/library/system.net.securityprotocoltype(v=vs.110).aspx

SecurityProtocolType.Tls12 was added in .NET 4.5, but it's not listed in the `4.5-api` reference assembly:

> $ monop -r:/Library/Frameworks/Mono.framework/Libraries/mono/4.5-api/System.dll System.Net.SecurityProtocolType
> [Flags]
> public enum SecurityProtocolType {
> 	Ssl3,
> 	Tls
> }

Consequently, projects which specify `$(TargetFrameworkVersion)` of v4.5 cannot use the SecurityProtocolType.Tls12 member.

We should presumably double-check our reference assemblies and ensure that they're correct.
Comment 1 Alexander Köplinger [MSFT] 2017-03-30 01:32:34 UTC
Fixed with https://github.com/mono/mono/pull/4619 and the corresponding changes to the reference assemblies.