Bug 53858 - Default Dialog box on iOS 8 is a transparent and translucent modal view.
Summary: Default Dialog box on iOS 8 is a transparent and translucent modal view.
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Paul DiPietro [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-03-23 14:33 UTC by TDA IMS Mobile
Modified: 2017-06-15 19:25 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot of the unexpected behavior. (95.15 KB, image/png)
2017-03-23 14:33 UTC, TDA IMS Mobile
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description TDA IMS Mobile 2017-03-23 14:33:13 UTC
Created attachment 20759 [details]
Screenshot of the unexpected behavior.

When calling   DisplayAlert(Title, Message, ButtonLabel) on iOS 8 in Xamarin forms we get unexpected behavior. 
The alert is completely transparent. We can only see the light blue "OK" button. 
We've tried the same thing with DisplayActionSheet(Title, Message, ButtonLabel, new string[] { "ok" }) and get the same behavior.

It's not an App breaking bug by any means. It just looks ugly. See the attached screenshot.
Comment 1 Paul DiPietro [MSFT] 2017-03-23 16:53:24 UTC
Which minor version of iOS and which version of Forms are you using?
Comment 2 Paul DiPietro [MSFT] 2017-06-15 19:25:43 UTC
Closing due to no response or reproduction for some time now. Please reopen with a reproduction if it's still an issue on the latest prerelease or nightly build.