Bug 53626 - Xamarin.Auth on UWP throws System.Runtime.InteropServices.COMException when Back pressed
Summary: Xamarin.Auth on UWP throws System.Runtime.InteropServices.COMException when B...
Status: ASSIGNED
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: N/A
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Miljenko Cvjetko Mel
URL:
Depends on:
Blocks:
 
Reported: 2017-03-21 10:58 UTC by John Hardman
Modified: 2017-03-21 13:43 UTC (History)
2 users (show)

Tags: Xamarin.Auth UWP exception
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 53626 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
ASSIGNED

Description John Hardman 2017-03-21 10:58:37 UTC
When using Xamarin.Auth v1.3.2.1 on UWP, pressing Back on the authenticator page results in the following exception:

"System.Runtime.InteropServices.COMException: Error HRESULT E_FAIL has been returned from a call to a COM component.\r\n   at Windows.UI.Xaml.Controls.Frame.GoBack()"

My suspicion is that Xamarin.Auth v1.3.2.1 is attempting to navigate from a thread other than the UI thread.