Bug 53511 - Xamarin.Forms Driod Project - Doesn't Show Tabbed Page Contents on Device but in Emulator
Summary: Xamarin.Forms Driod Project - Doesn't Show Tabbed Page Contents on Device but...
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-20 03:25 UTC by Isham Mohamed
Modified: 2017-06-15 01:59 UTC (History)
3 users (show)

Tags: map tabbedpage
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Isham Mohamed 2017-03-20 03:25:29 UTC
I have created a Xamarin.Forms project with Tabbed Page. Which was created in the below way
<?xml version="1.0" encoding="utf-8" ?>
<TabbedPage xmlns="http://xamarin.com/schemas/2014/forms"
            xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
            xmlns:mypages="clr-namespace:AnythingQA.Pages;assembly=AnythingQA"
            x:Class="AnythingQA.Pages.ShoppingPage">
    <TabbedPage.Children>
    <mypages:ProductItems Title="Products"/>
    <mypages:CartPage Title="Cart"/>
  </TabbedPage.Children>
</TabbedPage>
This works properly in UWP and Android Emulator but does not work in real Android devices - I have tested in Android 6.0 anf 5. This does not show the contents in the page. 

I have made a Xamarin Forums post as well with images, please refer https://forums.xamarin.com/discussion/91115/xamarin-forms-driod-project-doesnt-show-tabbed-page-contents-on-device-but-in-emulator/p1?new=1

Please solve this issue
Comment 1 Paul DiPietro [MSFT] 2017-03-20 04:43:00 UTC
If you have the time, please upload a reproduction project that is as minimal as possible as your sample code uses custom pages. This removes any possible confusion so we can see exactly what you want us to see in terms of code. More information such as the version of Forms you're using would be helpful as well. I would also always suggest a clean and rebuild, deleting bin/obj folders, as well as the local version of the app on your emulator/device.
Comment 2 Isham Mohamed 2017-03-20 05:04:45 UTC
Hi I have used Xamarin.Forms 2.3.3.193. and several times, I have clear and rebuild the solution. Another interesting behavior is, this works for UWP Projects without any issues. You can find my code -> https://github.com/IshamMohamed/AnythingQA/ and go to https://github.com/IshamMohamed/AnythingQA/blob/master/AnythingQA/AnythingQA/Pages/SelectLocation.xaml.cs Line 86
Comment 3 Isham Mohamed 2017-03-20 08:27:54 UTC
Hi, shall I get an update on this? I dont like to open my repository public for a long time.
Comment 4 Paul DiPietro [MSFT] 2017-03-20 14:04:35 UTC
From what I can see, something about the map page is causing the tabs to not show up, but this also occurs on my emulator. This will require further investigation, but if you have time and can minimize your reproduction to cut out any unnecessary code while still reproducing the issue, it can be uploaded here as a private attachment so you don't have to have a repository be public.
Comment 5 David Ortinau [MSFT] 2017-06-15 01:59:43 UTC
@Isham Mohamed 

I tried your GitHub project but it won't compile for me. As Paul requested, to troubleshoot this we need a minimal project that demonstrates the issue. 

If this is still an issue, please upload that for us and reopen this ticket for us to look again.