Bug 53475 - Indexer not recognized
Summary: Indexer not recognized
Status: RESOLVED NORESPONSE
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: 4.8.0 (C9)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2017-03-17 17:55 UTC by robertalmalak7
Modified: 2017-07-28 10:03 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description robertalmalak7 2017-03-17 17:55:49 UTC
Getting errors with Mono 4.8.0.xxx where a property 

 IReadOnlyList<TListItemViewModel> this[Category category] { get; }

is not recognized. Going back to 4.6.x.xxx would make it work again.

I think the fix 41602: Compiler fails to recognize Indexer that was done on 4.8.0 might have broken it.
Comment 1 robertalmalak7 2017-03-17 18:00:38 UTC
here is my error: 
Error CS0021: Cannot apply indexing with [] to an expression of type `TListViewModel'
Comment 2 Marek Safar 2017-03-23 10:13:52 UTC
Do you have a repro I can test?
Comment 3 robertalmalak7 2017-03-29 23:49:11 UTC
Nope dont have any, its production code. I would need to create a new project. But its really not that hard to add the indexer. Let me know if you can't reproduce.
Comment 4 Marek Safar 2017-05-30 09:50:46 UTC
I cannot reproduce the issue, we have quite few indexers tests but this looks more like generic type parameter issue (if TListViewModel it type parameter)
Comment 5 Marek Safar 2017-07-28 10:03:26 UTC
Closing. Please reopen if you have any info how to reproduce it locally