Bug 53464 - [d15-1 VS2017] Break-point is not getting hit when app is deployed in debug mode in iOS Device.
Summary: [d15-1 VS2017] Break-point is not getting hit when app is deployed in debug m...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.3.1 (15.1)
Hardware: PC Windows
: --- major
Target Milestone: 15.2
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-17 15:54 UTC by Neha Kharbade
Modified: 2017-04-06 07:02 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Attached Vs and Xamarin logs of Mac agent (99.28 KB, application/x-zip-compressed)
2017-03-17 15:54 UTC, Neha Kharbade
Details
Debug output for Crossplatform Application deployment and debugging. (742 bytes, application/x-zip-compressed)
2017-03-20 07:48 UTC, Neha Kharbade
Details
Logs (4.53 KB, application/octet-stream)
2017-03-23 10:19 UTC, Alok Kulkarni
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Neha Kharbade 2017-03-17 15:54:50 UTC
Created attachment 20440 [details]
Attached Vs and Xamarin logs of Mac agent

On Deploying CrossplatformDebug application on iOS device and Debugging it Exception is thrown.

Environment : 

Microsoft Visual Studio Enterprise 2017 Preview
Version 15.1 (26315.0-Preview) d15rel Preview
VisualStudio.15.Preview.Int/15.1.0-Preview+26315.0.d15rel
Microsoft .NET Framework
Version 4.6.01586

Xamarin   4.4.0.0 (b78a343)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK   7.2.0.1 (ff38526)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   10.8.0.17 (49a63dc)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.

Mac Agent :

=== Xamarin Studio Enterprise ===

Version 6.3 (build 834)
Installation UUID: 69f4e361-6bd8-4410-844f-3bd15ac993d7
Runtime:
 Mono 4.8.0 (mono-4.8.0-branch/8f6d0f6) (64-bit)
 GTK+ 2.24.23 (Raleigh theme)

=== Xamarin.iOS ===

Version: 10.8.0.20 (Visual Studio Enterprise Trial)
Hash: f94cf26
Branch: d15-1
Build date: 2017-03-14 12:37:51-0400

=== Xamarin Inspector ===

Version: 1.2.0-rc.3
Hash: 5e5e341
Branch: d15-1
Build date: Fri, 10 Mar 2017 22:41:39 GMT

=== Xamarin.Mac ===

Version: 3.2.0.20 (Visual Studio Enterprise Trial)

=== Xamarin.Android ===

Version: 7.2.0.2 (Visual Studio Enterprise Trial)
Android SDK: /Users/globallogic/Library/Developer/Xamarin/android-sdk-macosx
 Supported Android versions:
  4.4 (API level 19)
  6.0 (API level 23)
  7.0 (API level 24)
  7.1 (API level 25)
   
Steps to reproduce :

1 Pull the QA repo
2 Build, deploy and run QualityAssurance/Manual/CrossPlatformDebugging/CrossPlatformDebugging.sln
3 Run all the included tests.

Actual result: Applied break point is not hitting instead it is firing a exception.

Expected result: All test should be executed properly.

Reproducible: 100%

link to Screencast : http://www.screencast.com/t/RmjZaTrQN

Attached : Xamarin zip Logs and Stack-trace of build output
Comment 1 Joaquin Jares 2017-03-17 17:22:37 UTC
@Neha what exception are you getting? Can you attach a screenshot of the exception?
Comment 2 Joaquin Jares 2017-03-17 17:24:43 UTC
Sorry, missed the screencast.
Comment 3 Joaquin Jares 2017-03-17 19:16:58 UTC
2 questions:
1. Can you debug _any_ iOS app? Is this specific to this app?
2. Please attach debug logs. That's the output in Debug -> Output.

Thanks,
j
Comment 4 Neha Kharbade 2017-03-20 07:48:58 UTC
Created attachment 20452 [details]
Debug output for Crossplatform Application deployment and debugging.
Comment 5 Neha Kharbade 2017-03-20 07:51:15 UTC
@Joaquin answer to your above questions :

1. I was able to debug iOS Singleview Application.
Comment 6 Jose Gallardo 2017-03-20 10:15:01 UTC
Can you confirm if you can also debug the iOS application in a new cross platform Blank App - Native - Shared ?

Thanks
Comment 7 Alok Kulkarni 2017-03-23 10:19:47 UTC
Created attachment 20730 [details]
Logs

@Jose, I can debug the iOS application in a new cross platform Blank App - Native - Shared.

Sharing the build environment and IDE logs:
OS : Windows 10
Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Xamarin   4.4.0.7 (0b7edd0)
Xamarin.iOS   10.8.0.26 (0e9e791)
Xamarin.Android   7.2.0.6 (b8e3884)
Comment 8 Aman Dharwal 2017-03-31 07:57:38 UTC
This bug is Resolved
Comment 9 Alok Kulkarni 2017-04-06 07:02:27 UTC
Bug is verified hence marking this as verified.